Error Code X86-64

I keep running into the same error in working with sketchup/layout.
Code: X-86-64. The files I am using were working properly but when I delivered them to my team and received them back they stopped functioning properly and I am having continued crashes when trying to execute certain functions. I am on a Mac platform and they are on windows and we thought it may be a compatibility issue but they are not having this same issue with other people using Macs.

Basically whenever I try to update my linked sketch up files in layout the program crashes. This will happen regardless of which method I use to relink the files. I tried to completely delete the scenes and re-insert them but when I do this is shows the previous iteration before I made changes so does not actually update the file.

Also I have two working sketch up files, one building model and one site plan model which has the building model linked to it. If I make a change to the building model and then try to update that change in the site plan file it also crashes and gives me the same error code: X86-64.

Do you have any insight or suggestion to resolving this issue?


Can you upload the file for examination? It may provide a clue.

1 Like

Hey there, Thanks so much for the reply and sorry its taken me so long to get back to you here. I am not able top upload the file because it is too big. 16mb size limit. Not sure if there is a good work around for uploading bigger files? I could email it to you.

The usual way is to load it to a cloud service (Dropbox, Google drive, WeTransfer…), share it and post the link here.

1 Like

With system errors it’s worth searching for any report of the error, and not limit the search to SketchUp things. There are a lot of reports of that error, including this report, where another piece of software was apparently causing the problem:

1 Like

I don’t have a solution, but here are a few thoughts:

  • It’s probably obvious, but if the issue occurs only with files that make the round trip to Windows and back, there is likely something going amiss at your Windows colleagues end. SketchUp uses the identical file format on both Windows and Mac. If this were a matter of WIndows SketchUp itself mangling part of the file, I would think we’d be hearing of more issues of this kind. So perhaps this is due to something non-SketchUp binary they added at their end (e.g. an image, perhaps in a material) that is somehow unacceptable to Mac.
  • Where are you seeing that message? So far as I know, X86-64 designates the 64-bit Intel x86 architecture and is not an error code as such. There must be more to the message…
  • In the link @colin provided, the issue appears to be malware that is tampering with the Safari executable. The error trapped was an attempt by a different process to start a new thread within Safari, which is a security violation. I don’t think that is what you are encountering.

As written earlier, if you can share a sample skp and layout via a file sharing site, people here can see whether they hit the same problems.

1 Like

Hey everyone, Thanks for helping me out. Here are links to the sketch up and layout files:



My co-workers said that they are not having the same issue when they try to update the layout files on their windows platforms. I’d be very curious if someone on a Mac platform was having the same issue or not, which could help indicate if it’s a malware issue or not. I would be surprised if it is malware as I don’t visit any questionable sites or download anything that’s not from a trusted source for this very reason… but I’m sure malware can find ways in.

Here are screenshots of the error reports I am receiving:

Sketchup File:

Layout File:

hmmmmm I’m not seeing any signs of anything like that on my system. Not completely counting it out but not finding any traces of malware at the moment.

OK, in both the Bug Splat and the crash report, there is a matter of knowing how to read these reports. The line saying “Code Type: X86-64” is telling you that the app that crashed was compiled to run on a 64-bit Intel x86 processor. The actual error is down lower. In one case a SIGBUS and in the other a SIGSEGV. Both of those result from serous bugs in the app that have caused it to access illegal memory addresses. The SketchUp developers can nail it down to where it occurred and maybe figure out why, but it is beyond us mortals.

1 Like

Thanks for the insight. Is there any way to contact the developers and see if they have any suggestions? Curious if you have any thoughts on why I would be having these issues on my end but my co-workers are not?

Much appreciated.

If you submitted the BugSplat with contact info, they should see it. On submitting the bugsplat you should have been relayed to a web page with an error number. If you post that here it will help them to find the report. If you didn’t submit it, you are probably too late.