EP_Fastener plugin with sketchup make 2017 or 2015

Hi everybody,
I want make fasteners and screws wiith sketchup make 2017 and I had found only EP_Fastener plugin to do that, but even with old version of sketchup 2015 it is not working. I can’t make threaded hole and screw look like a giant screwbut not a M8 size for example!
So I guess what is wrong (incompatibility of the plugin and if I can’t use it what other solution is existing?
I don’t know if plugin could be used with Web Sketchup?
Thanks for your help

How about uploading an example .skp file that shows what you are getting with the extension. It does work in versions up through 2018. Maybe you are just running into the small faces issue.

How do you plan to use the fasteners you are trying to model?

Hi Dave,
Thanks for your help and rapid answer.
I have done a skp file where I tried to build a crew 8M 30mm length and drilled holes. The full drilled hole was not created but only hole on surface. When I want create threaded hole the plugin closed immediatly. I have same results with sketchup make 2015 or 2017.
Beside I have opened the ruby console and seen errors.
.ThreadBox2015.skp (224.5 KB) RubyConsoleThreadedHole.txt (4.7 KB)

Hmmm… I just made an 8mm threaded hole 30mm deep in your block. This is in SU2020 but it worked the same way in all previous versions back to SU2014.

When you installed SketchUp did you right click on the downloaded installer and choose Run as administrator?

As I asked before, what do you plan to do with these threads once you have them?

Hi Dave,

To answer what I want do with these bolts an fasteners is to build 3D objetx in PLA, only to maintain a tree cat broken for my cat ! :yum:
No needs to get precision , …

About the installer, no I hadn’t used administrator privilege, so I will try it.



1 Like

For something that size you might find it better to just model a hole and then use a metal press-in threaded insert like these, below. You can heat them with a soldering iron and press them into the PLA.

Screenshot - 5_14_2020 , 8_27_26 AM

Hi Dave,
I have downloaded Sketchup Pro 2018 and install it with admin right. I also launch it with admin right.
But I have the same result as before.
I have seen an alert message when installing EP_fastener that advice me that Os version of Sketchup version could be incompatible with this plugin!!!
My OS is Windows10!
So what could be the problem?

There shouldn’t be any need to launch SketchUp with admin rights.

The compatibility message is probably just telling you that the extension hasn’t been marked as compatible with the version of SketchUp you are using. If you look at the Extension Warehouse page for it, it shows compatibility for only 2014 and 2015 however that by itself doesn’t indicate that there’s a problem with the extension.

My example from yesterday was done in SketchUp 2020 and it worked fine. Ugly threads but the extension did what it says it’ll do. I just opened SU2018, installed EP Fasteners in it and ran it. It works fine here.

There must be something wrong on your end if it isn’t working. Are you using the right units?

I have installed this Extension also. It works for me on SU2020. I have noticed that it won’t produce the results in a component like you would expect. You need to apply it to a primitive face. Is that how you use it Dave. I may be doing something wrong also.

No, Michael. What you see is the way it is designed to work. It creates a hole-cutting component so it has to be applied to the raw geometry. You aren’t doing anything wrong.

As for me, I only use it when someone is asking about using it. If I need decent threads in a model, I don’t use that extension. It doesn’t make real great threads. If I don’t need the precision in the threads, they I would probably use a texture to help control file size.

I agree Dave. It makes the file to0 big and doesn’t serve any purpose.

1 Like

Unfortunatly it is not working whatever the version used! I have tried wit 2 different PC same result KO!
For threaded hole the plugin close itself before choosing diameter !!! :frowning:
Is this plugin working with SU without PRO licence?
Are you using pro version of sketchup?
What Wndows version are you using? => Windows10 for me
I relally don’t understan what’s wrong.
Thanks, regards

It has to be something on your end. The extension does work and it does not require a pro SketchUp license.

As I wrote:

That’s pro-only

I’m using Window 10.

Might be a graphics card issue or the way you installed SketchUp. What is your graphics card? Please complete your profile.

OK. I installed SketchUp 2017 Make on my Win 10 laptop, installed EP Fasteners and it runs fine. Here’s an M8 hole 30mm deep.

Hi Dave,
My graphic card is an AMD Mobility RADEON HD5000, but I don’t believe that it is the root cause because it doesn’t work also with newer PC and graphic card and , when I open plugin all worling well and when it works I see correctly the result inside sketchup!!!
With Web version of Sketchup could we use plugin?

No. there is no implementation in the web version for extensions and plugins.

When you use EP-fastener what messages you have in Ruby Console whzn you make a drilled hole and a threaded hole?

I just made another threaded hole in SU2017 Make with the Console open. This is all I see.

Since you can’t get it to work on your machine maybe it’s just time to learn to make them another way.

Hi, See the difference when I want build a tappehole where the EP_fastener dissapears when I click on Threaded hole:

What is it the version of EP_fastener you are using? I believe 1.0.0 from 2.01.2015, right?
So I believe the problem should be inside JSON library or other interpreters of language used for *.rb files that provides this error and abort.
I will see in this way, I don’t shoot my last bullet! :wink:

The extension is assuming that you’re using ‘.’ as the decimal separator, but I’m guessing you use something else like comma ‘,’.
What part of the world are you in and which character do you use for the decimal separator?

Do you use 5.5mm or 5,5mm ?

If you have your operating system’s region or language settings to use commas as decimal separators and try to convert a string to a Length like this:

> '0.0'.to_l
Error: #<ArgumentError: Cannot convert "0.0" to Length>

You’ll get that error.

You could either change your locale settings or edit that extension so that it works. If you changed line 26 in EPTappedHole.rb from this:

@@ZERO = "0.0".to_l
   to this:
@@ZERO = 0.0.to_l

It would fix that one error, but there’s lots of others in the code so it would need rewritten. I can’t run it myself as it’s a windows-only extension. I haven’t looked at the whole thing to see what’s Windows specific in there.

Before you go editing the code, just try this in the Ruby console. Paste this in and press return:


Then try:


One will work and one will give an error.

You should really contact the extension developer and ask them to fix it.

1 Like