Empty sketchup file on iPad

Hi I’m new here, so I was using a free web version to create a pop store, then I downloaded the app on my iPad Pro 11 m1 2 TB unit and subscribed to a plan. I tried editing the file that I have made from the free web version, but it crashed and now the file is empty. I don’t know what to do as the file is important and it was a lot of work to recreate it.

Were you working on a copy downloaded from the web version, or is it all stored in Trimble Connect? Is it possible to go back to the web version and download another copy?

It automatically sync on my iPad once i logged in on my account, and it was on Trimble Connect. I was able to open it on my iPad then when I use rotate and zoom, the artwork banished and got stuck with an empty one. I tried reopening it on the web but still the artwork doesn’t show. kindly see the attached for reference

Thanks for sharing the video @XaiMallari

I’m trying to think of some tips that might help, and I’m looking at the screenshot that you shared of the Home Screen, where an earlier version of the model, and the relative file sizes of the earlier and newer versions… curious whether you imported anything from 3D Warehouse when working on your design?

Also curious whether at any point you might have pressed zoom extents?
It’s possible that after either pressing Zoom Extents (or after using the quick pinch gesture to Zoom Extents), SketchUp zoomed out to show you the entire contents of your model, and when it did that, it zoomed out really really far. So far, that your model is but a tiny speck at the origin. This can sometimes happen as a result of importing wonky stuff from 3DW.

To check to see if that’s what happened, you might try using the Select All command (available in the tool mode toolbar when the Select tool is active, or press Command+A if you have a keyboard) to see if there are any selection bounding boxes that appear in the model (and/or whether the entity info panel suggests that you have anything selected). If it looks like there might be something in the model, you might try to zoom in repeatedly toward the origin, to see if you can find it again.

Lastly, I doubt that you accidentally hid everything, but it never hurts to check the Tags and Outliner panels to make sure that everything there is toggled on.

Please let me know whether any of that helps…

If you’ve somehow, truly lost everything in the model, I can show you how, in SketchUp for Web, to access the file’s revision history in Trimble Connect an retrieve a past revision.