Embedded links to 3d warehouse not loading

Suddenly none of the embedded 3dwarehouse links that we have on our website will work. The frame that you click into comes back with ‘The specified model could not be loaded’. I’ve tried refreshing the links with new ones but this has no effect.

The only change that has been made was adding a URL to my 3d warehouse page (which I’m assuming should make no difference).

Any help would be amazing as we rely on these models quite heavily.

Can you link to a page where you have one embedded?

Thanks for coming back so quickly. Yes, here you go - How to insulate a pitched roof using wood fibre insulation | Back to Earth

hmmm @TheGuz , could it have something to do with you guys tinkering in the warehouse Lab maybe ?

1 Like

Looking at your links there is a slight difference between the links on your site and the ones that 3DW is generating for me.

the &

is just a & on the new code

I guess it could be a change at SketchUp’s end or something on the webserver has changed.

in any case, if you swap the & for & the links work

Thanks for looking into this. So I just need to paste in ‘&’ into the code? It’s great to have a solution, thank you. Might take a while so correct it all though.

Thanks so much for your help.

I imagine you could run a find and replace on the pages where the embeds are



As you are using wordpress, there are plugins to help you do that
Better Search Replace – WordPress plugin | WordPress.org

You’ll just want to eyeball each one to make sure you aren’t changing something else using the same string! Which is possible

Thanks very much. It’s a great service you provide here!

Actually, I can’t seem to get this to work. I’ve just tried again and pasted this into Wordpress -

My html seems to already have the correct code doesn’t it?

If I look at the source of the page I see this

I’m sure someone more familiar with web tech will know more about why that does/doesn’t work - it’s the same information, just encoded differently.

Hmm. When I use the page inspector in Safari I don’t see that, nor in the html in Wordpress. What I am seeing though is the attached screenshot which might actually suggest this is nothing to do with 3dwarehouse

If you use the link in the embed - even in the address bar


this doesn’t work -

but if you change that =& to &


it loads. I feel like something somewhere is getting confused by that - perhaps one of the other parts of the 3Dwarehouse viewer doesn’t accept it anymore where it was fine previously?

Yes, I can actually see it now. When I type & into Wordpress it seems to change to & Thanks for your help Adam. I don’t think this is a 3dwarehouse issue. Seems to be more to do with Wordpress I think.

Hi. I think you may be correct. For some reason 3dwarehouse will send the thumbnail through but no longer allows the model to load because the code contains the “&” symbol. When I save this in Wordpress it gets changed to “&” which is no longer acceptable for loading the model for some reason but works fine so long as it stays as “&”. Not sure why it is fine for the thumbnail though. I only noticed the issue yesterday AM.

Sorry, this editor also changes it. “&” gets changed to “& a m p ;”.

It would probably be wisest not to use “reserved” characters in file names.

1 Like

& is the HTML code for the & symbol

if you type & you get an &
but if you type & in your code, you get… something else (my html/css course is from 2013, I don’t remember all)

I tagged the Guz in my first message because he is part of the warehouse team. and you’re right, it might be a wordpress thing (with their WYSIWYG editor, the & might work as an &) but as they are developing the warehouse these days, who knows, they might have updated a library or something.

1 Like

Yes, I agree. Not sure why they use it in their embed code.

Hi Adam


This is the bit of problematic code from the link. I have removed it and everything works fine again. Can you see any reason why I shouldn’t just remove this out of their embed code?