Either bug or intent - New - no thread for this found

I had a case recently where suddenly someone was having right-click menu appearing after several seconds, and the Edit menu contextual sub menu would never appear. The customer was getting a bit upset about it, but managed to track down the problem to FredoGuides.

If you use that extension take a look at where I asked Fredo6 about it, and try the later version he made to try to solve the problem:

Wow, only great responses this time, impressed, thanks so much to everyone!
As offered, and requested by @slbaumgartner and @Geo I try to insert the file here. Despite my risk that “everyone” might have a laugh at us aka “what, you didn’t notice WHY it suddenly fails? You stupid user you!”…

@colin 's hint (“The customer was getting a bit upset about it, but managed to track down the problem to FredoGuides”) is interesting as it is along one of my own ideas that maybe an accidental keystroke “wrongly” started some extension. However, Colin’s case description is entirely different, but yes it could be another such issue, why not.

@DanRathbun: “Is it outside the SketchUp applications window ?”, Sorry, with “OUTSIDE the model” I meant inside the application window, just outside our actual model context.
When/If you see the file: the weird new dotted rectangle is the one you see LEFT. (the components briefly set aside on the right were on purpose).

“ESC key” no change
“mouse” is great
“update history” we would NEVER allow silent background updates, nor should you :wink:

" reboot the computer to refresh all memory" - this one is interesting, we didn’t do THAT because it stops (gosh) all other apps running and needed. ALSO because: can “memory actually get corrupted” in such way that still any other model works well, and ONLY the weird one does not, suddenly?
I am not geek enough to know, only you are, Dan.
My guess: no. Then NO model would work anymore.
??

Now here’s the promised file, as said, it’s a model from 3DWH, just changed a lot already.
Floor plan II.skp (610.1 KB)

Change the camera to perspective, see if that brings normal operation back.

To me it did. Perhaps, too, the fact that the view it opens in is from the bottom up has to do with it.

It is a variation of the problem where some items are an infinite distance away. I have an extension that fixes that issue, and your model now works.

The items that were previously a long way from the origin can be seen in the outer area of the model.

Floor plan II.skp (609.1 KB)

2 Likes

Bingo. Once camera is set to perspective and operation resumes, zoom extents reveals the problem.

The dotted rectangle you see is hidden geometry which you have set as shown in this model.

1 Like

The others have set you on the path again, but I’ll chime in with some details so you can avoid a repeat:

You fell victim to the (now well-known) “singular text” bug. There are four leader texts (ones created with this tool Screen Shot 2020-02-12 at 1.33.33 PM ) in the model that have flown away to infinity.
These texts originally said:

  • Master Bed 1
  • Kitchen
  • Great Room
  • WIC

Once one or more texts have flown away, if you zoom extents or sometimes orbit or zoom in other ways, SketchUp moves the camera away to infinity in an effort to make all of the model including those texts visible. That causes all the geometric contents to shrink to invisibly small. The bug can also cause other strange effects, e.g. your inability to select anything, because SketchUp is straining to figure out where everything is.

The bug is triggered when you are working on a basically 2D (planar) model, attach a leader text to a face in the model, and later edit the model in a way that either erases that face or causes it to merge with an adjacent one. It doesn’t happen absolutely every time - sometimes you can get away with such edits, which lead to confusion because based on experience you didn’t know you were doing anything wrong.

This bug was present in versions of SketchUp up to and including 2018. An imperfect fix was introduced in 2019 - I say imperfect because it may leave the text pointing at nothing, and you can’t reattach it. The script @colin ran was generously provided by (I think?) @sWilliams specifically to repair this issue.

To avoid causing this again, the only known method (short of upgrading to 2019 or 2020) is to avoid attaching leader text to a 2D model until you are finished editing the geometric contents. Ignoring this advice is playing with fire.

1 Like

It was swilliams. Here’s the discussion that ended with him making the extension, and the RBZ file is in the last message:

Thanks to everyone not bashing us (this time).
Great feedback, thank you all.
In fact Steve’s explanation explains it so well I now understand it too:

As said, it is a model downloaded from 3dWH, the leader texts were in it. Sure, our changes then “must” cause the known bug to surface. But since we didn’t see anything in “infinity” we didn’t even suspect it could be the same bug.
Nor did we create hidden geometry.
I suspect, like before, it’s an input error, when too quickly using hotkeys.

Colin’s script that solved it I’d be interested in, and I will look for @sWilliams ’ post of it that Steve mentioned.

@colin: Your corrected model DOES work, yes, confirmed, thank you for fixing it :slight_smile:

@slbaumgartner: “avoid attaching leader text to a 2D model until you are finished editing the geometric contents. Ignoring this advice is playing with fire.” - crucial advice, thank you.
So I guess the advice then actually is: “Delete any leader texts that you see in models you download from 3DWH if a 2D model, or you’re playing with fire” ?

And THAT indeed is both new to me, and an essential tip for anyone I guess, hence why I thought I spell it out once more :slight_smile:

Depends what you are intending to do with the downloaded content. The bug is triggered when you edit the model in a way that alters a face that has a leader text attached. Certainly deleting all of them will make it impossible to trigger the bug until/unless you add some of your own.

This in one reason many of the SketchUp experts advise using LayOut for all annotation, though that doesn’t help you if you only have SketchUp Make.

Yes I guess most people who download models from 3dWH either do it to use them as basis for their own new model (if suitable/good), or maybe just to learn from the model (if super good) ?

So the safest thing for the computer that has make17 on it is indeed to delete texts in downloaded models of said type (2D you said).
I interpret your tip to suggest that once a model extends items into the z axis (3D) the bug cannot even surface at all.
Interesting bug, really. I wonder what it’s code is so to say.

FWIW, some of us discussed the bug with one of the developers at DevCamp 2018, and he came up with the fix that went into 2019. He didn’t tell us exactly what he did, but I suspect the cause was that the code tried to recompute the anchor point of the leader based on the deleted face, and got nonsense coordinates back.

Do you have a link to the 3DWH model? We could at least ask the author to update the model, as well as use it as a test file.

That makes sense, yes. I guess, what I would have done to solve it then is, to simply put any “orphan” texts to axes’ origin, even if 5 end up there, no bug then, you can just delete yourself the texts you no longer want.

@colin: No Colin, I don’t have the link now, but my upload here was the original file name, so we could have a look if 3DWH’ search engine allows to search by filename, we’ll see.
I do realize however, that quite many models in there are from SU “beginners” and that’s not an insult, I count myself as one and always will.

I just ran the test myself: No WH does not. Neither Floor+plan+II.skp nor Floor+plan+II brought up results.
Hm, wouldn’t it be great to make that tiny improvement to the WH search engine?
By filename?

And finally: I think I realize what causes the issue as well:
When you delete (not a face) but just an edge, an edge from which the author generated the dimension text (with arrows), then the bug seems to surface as well.
Because she did work on walls, deleted edges,… one had a dimension “attached”…

When you delete an edge that borders a face, that face must either also be deleted or merged with a face on the opposite side of the line. That specific edit was the proof case that led to understanding of the bug!

The file name seems to be made up from the title, but without spaces. I found the model by searching for floor plan ii.

Great. And yes, I assume (like most search engines) the 3DWH one simply replaces spaces with +
The downloaded file has pluses, so you are right, the actual file likely was uploaded with that name with spaces.

And indeed, searching for “Floor plan II” DOES bring up Ranolito C.
So I take back my suggestion to to add by filename to the WH search: it is already there, more or less. :slight_smile:

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.