Edit In Place opening new window but my component isn't there

When I highlight a component and click on “Edit In Place” it opens up a new window but isn’t showing anything except the woman standing there like I want to make a new drawing. Any idea what can be causing this?


Just to complement, this is about the extension “EditInPlace” (You should provide that info to help people understand the subject you are talking about.)

A wild guess is that the plugin functions by exporting the component to a file, launching a new (independent) instance of SketchUp and passing to it the file to open. If something fails, SketchUp starts normally and shows an empty new model.

  • Maybe it fails to export (directory not found, not accessible or permissions issue).
  • Or the component’s file path fails to be passed as startup parameter to the application. Assuming the component’s file is exported to your temporary folder, find the location of it and check whether it contains special characters or spaces. Does your username have special characters?

Report the issue to SUPodium so that they can inspect it and fix it.

1 Like

I think that @Aeriliusis right. You should contact the author directly to see if they have a solution.

What is the benefit of editing a component in a separate SU window?

IMO “edit in place” is what happens when you double click on a component in SketchUp.
Why name a plugin “Edit in Place” if it does just the opposite. “Edit separately” would sound more appropriate to me.


Agreed! I’ve been trying to think of a benefit to editing a component separately in a different window but can’t think of any. That’s why I asked.

Sometimes you don’t want other components to see what you do when you get them alone.
Perhaps the plugin should be called ‘edit in the back room with the blinds drawn and cameras shut off.’


The origin of the component might be somewhere very far, if you hit ‘zoom extends’ do you see something happening? Or check the entity info panel and press Ctrl A, something selected?

I tried zoom extents and nothing is there

I agree…“Edit in place” does the opposite of what it says.

I am not finding the temporary file in my temp folder right now but am still working on figuring that out.

I use EditInPlace because I have to make a lot of revisions to different components and my computer locks up or runs really slow when I try to do it all in one place. When I “EditInPlace” it allows me to make large revisions to a single component a lot quicker. Does that make sense?

Have you tried setting everything else to be hidden while editing the component?

You can manually right click on a component and select Save As to save it as an external file, then browse to that file, edit it, and right click the component and select Reload to load it back in to the master model. Same workflow as with the plugin but manual and with better control where the files are located.

Try hitting Zoom Extents.
When I first tested it nothing showed, I hit shift+z and it showed the model and continued to work correctly after that, with new models.

I have been doing this and it works great. Thanks for the advice!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.