Dynamic components missing from Toolbar in 2019 Pro

I am trying to “turn on” dynamic components, without which a parametric plugin I have will not work…

When I look at the View/ Toolbars menu (below) I see that it is missing…
Any ideas for where to look?
Thanks!

image

have a look at window->Extension Manager and enable the extension

Did you look in the Extension Manager to see that it is enabled?

Did you install SketchUp correctly by right clicking on the installer and choosing Run as administrator?

1 Like

Thanks for responses.
Yes, it is enabled…
The extension is PlusSpec…

Looking for the dynamic components checkbox is the advice their tech support gave (for why it won’t extrude it’s own walls)…

Did you try the other way around?
Stop and start SketchUp, in between.

I just learned that DC is a plugin and not native…
I installed it and that fixed the issue.

Thanks everyone!

Actually, Dynamic Components is a native extension shipped with SketchUp Pro. The fact that you had to install it separately would indicate SketchUp wasn’t installed properly in the first place. It would have been installed automatically with proper installation of SketchUp.

DCs is an Extension, BUT it is in the ‘Shipped’ folder created with the main SketchUp installation.
All of the ‘Shipped’ Extensions auto-load as SketchUp starts - the folder’s contents are copied into the main user’s ‘Plugins’ folder, then loaded.

If they fail to appear it’s indicative of SketchUp having been incorrectly installed.
Try ‘repairing’ your installation thus…
While you are logged as your usual Windows user-account [NOT the system administrator, but if your normal user has some admin-powers that’s OK] - ensure SketchUp is closed.
Find the relevant installer exe file - probably in your user’s Downloads folder ?
Select the installer’s exe file’s icon, right-click > context-menu > “Run as administrator”
When prompted choose “Repair”.
When it’s completed restart SketchUp and see what’s changed…

If you install any complex app in any other way you can get all sorts of weird and unpredictable problems - often relating to file/folder permissions, including the ‘Shipped’ file/folders failing to be copied over !

NEVER double-click an installer’s exe file to ‘Run’ it.
Even if you have some admin-powers the result will not be the same !

Report back…

1 Like

I had the same issue too. Uninstalling ALL the extensions, including DC helped. After SU restart, all the default extensions, like DC, Sanbox and others were present and working.
Could be that some of other installed extensions was breaking DC - but I did not investigate which.