Dynamic Component Tools

When I create an attribute for a component and select allow user to modify in a text box, nothing shows up in the component option box. I’ve tried this both SKU 2019 and 2020 with the same result. I am on OSX 10.15.3. My graphic card is an AMD Radeon Pro 5500M 4GB
Couple of screen shots:

Post a copy of the component file.

I went to the extension warehouse and downloaded the latest dynamic component extension from Trimble, restarted SKU and now it works. Hope this fixes the issue.

1 Like

Do not use the toolbar icons, it is a bug. (On Mac)
The order of opening is triggering it (I do not recall which you should open first)
Use the rightclick method, instead.
If you do run to it again, disable the DC in Extension Manager, close SketchUp and enable them again when you open SketchUp

1 Like

Thanks for the information. I’ll work with it. Curious that issue is present in both 2019 and 2020. Guess they copied the problem over to the new version. Downloading the update to dynamic components seem to help.