Dynamic component doesn't work anymore


#1

Dynamic components that used to work fine, now come up with this error message
DynamicComponentError
Anybody know why? How to fix it?
I’m using SU Pro 2016


#2

Did the DC come from the 3D Warehouse?
If so, post the 3DWH URL here so we can have a look.


#3

It didn’t come from 3D Warehouse. It is a component I made and was using for a long time without problems.
But I may have used it only with SU8, although I thought I had used it with SU 2016.DynamicDoor.skp (264.0 KB)
I uploaded a file with the component in it.


#4

It works fine here.


#5

Blockquote
Did you open the Component Options window and try to change any of the parameters?
I can load the window and perform the actions, but when I open the Component Options window and select the component, I get this error messageDynamicComponentError
Are you using SU 2016 or later? (I am using SU Pro 2016)
Could something be screwed up in my Ruby version or installation?


#6

I’ve seen that message. Then I updated the DC package and the message never came back.


#7

How do you update the DC package?

I tried using this component on a different computer, also with SU Pro 2016. It worked. So there is something messed up in my installation. Maybe updating the DC package will solve it. Can you tell me how to do that?


#8

Go to the Extension Warehouse and download/install the latest version of Dynamic Components by the SketchUp Team.


#9

Blockquote
Thank you. That solved the problem.