DXF Lines Import as Faces

I am trying bring in land survey contour lines into SketchUp to build a site with. I have an SVG of all the contour lines in vector format. I converted this SVG to DXF using CloudConvert (https://cloudconvert.com/svg-to-dxf).

When I go into SketchUp > Import and import the DXF, all of the contour lines come in as a line thickness with a face instead of just lines. In other words, where one line should be, there are two lines with butt ends that form a face of the line thickness.

I thought this might be due to how the vector file line weights might be impacting the export of the SVG. I’m using a Mac app called Affinity Designer as part of a method of getting raster image lines converted to vector. In Affinity, I set the lineweight to 0pts and exported the SVG, but after going through CloudConvert to DXF and importing into SketchUp, I still get a lineweight face instead of just the single line.

Does anyone have any ideas about why this is happening or how to get JUST LINES?

Thanks for the help.
macOS 10.14.6 | SketchUp Pro 17.3.116

Attached is a screenshot of what I’m talking about.

While I did not find a definitive answer as to why SketchUp imported this DXF of lines as faces instead, I suspect it ‘might’ be the SVG to DXF converter. I found a tip in at post in the Import SVG image and extrude based on contours article that provided the solution.

I ended up downloading/installing Inkscape (Inkscape.org) for the SVG to DXF conversion, which worked great AND came into SketchUp as just lines. My Inkscape procedure was…

  • Open SVG in Inkscape.
  • Save As > Desktop Cutting Plotter (AutoCAD DXF R14) *.dxf.
  • Options: use LWPOLYLINE type of output with a Base Unit of “Inch”.
  • All other default settings.

The contours came into SketchUp (Pro) just as lines, quick and easy. It appears that was not a SketchUp issue but rather an issue with two separate online based SVG to DXF converters? Though that is not confirmed.

Probably the polylines in your original DXF had their width attribute set to something else than 0. It might be that it was caused by CloudConvert. Or then, Affinity, when vectorizing, creates filled regions instead of single lines.

Good explanation, that sounds very plausible. Thanks.