Bug in DXF import in 2017 version

2017
dxf
import
bug

#1

I used Img2CAD to create a dxf file using outline - import works fine in Pro 8, Make 2014 but in 2017 the import is not correct - some lines disappear and some lines are weird.

You can get the dxf file if you want to investigate.


#2

You could post an example here (a small file, please). Usually raster to vector converters are a waste of time.

Anssi


#3

It depends on the purpose if they are a waste of time or not :slight_smile: .
Here is the dxf file: Hospital2.dxf (12.7 KB)


#4

cannot reproduce this here, am getting in SU 2017 x64 Windows the identical result (import unit: meters) to what I see in the (free) ‘Teigha Viewer’ f. Windows & Mac OS. The whole object consists of 3D polylines which are converted to edges in SU during import.


#5

Mac and PC version of 2017 creates the same result


#6

Version 8 pc /2014 pc /2016 mac versions all creates this

Some of the lines are very different - like the ones I have marked.


#7

The scale in your DXF file is extremely small. It is obviously a floor plan, and when I import it using Meters as the import unit, the interior walls are something like 35 mm thick. So if you use a small import unit like a centimeter, millimeter or inch, the endpoints of many of the lines fall within SketchUp’s tolerance limits which causes them to merge, as shown in your screenshots. There is nothing new in this. You were previously probably using a larger import unit than now. Check the settings behind the Options button on the File Import dialog box.

Anssi


#8

Hi Anssi,

Thanks for reply - I have checked and you’re absolutely right - setting the import units too small causes the problem - so probably the defaults have changed - but now I have learned something new about Sketchup, thanks!