SketchUp 2021 does not import dxf files correctly anymore?

I am a professor that has been using SketchUp to visualize 3d outputs (in the form of dxf files) of forest simulations since 2011. Starting with SketchUp 2018, the software no longer correctly reads colour data.

SketchUp 2018:
•Can not drag and drop dxf file onto window to open.
•Incorrectly reads some blocks
•Displays model at incorrect dimensions
•Does not display model colours
•Is very slow at displaying model (relative to SketchUp 2017)

SketchUp 2021:
•Incorrectly reads some blocks
•Does not display model colours
•Is very slow at displaying model (relative to SketchUp 2017)

Are these known bugs? I enjoy SketchUp, but the inability of new versions to correctly display models that older versions showed makes me concerned.

Help?

1 Like

SketchUp 2017:

SketchUp 2021:

SketchUp 2017:

SketchUp 2021

It is impossible to say from a screenshot, but to me they look identical except the coloring. I wonder if you are using a Cololr By Layer style in 2017 and not in 2021.
Can you post a DXF that “misbehaves”?
Check that your import unit is set to the same as is used in the DXF in Import options (button on the Import dialog)

@Anssi sure, I can upload an example that is acting odd. And you are correct that that the 2021 version gets the units correct. The 2018 version doesn’t have the option to check the import units and is lol (attached). I will attach an example dxf in the next reply.

Here is the DXF

noWaterNoTerra200yrs200.dxf (1.5 MB)

Yes it does. Click the Options button in the Import window.

For anyone concerned about SketchUp performance: Try navigating the DXF @seanth posted in AutoCad or TrueView. It is a dog in SketchUp (over 6M edges) but in TrueView every view change takes minutes, especially in a shaded display mode.

Everything in the model is on layer 0 and I didn’t manage to find in it any materials either. Was the model you used in older versions of Sketchup somehow different?

I figured out the problem, though I’m not sure what introduced the issue.

2017 couldn’t import materials, but did seem to pick up the used colors, and add them as materials. 2018 fails to do that. With 2021 there is an option to import materials. Make sure that is checked.

The next thing to notice is that all of the ‘trees’ are the same component, and yet they are different colors. That could only be the case if the component was colored, if the internal faces were colored, they would all looked the same, and attempts to color the component would fail.

The times when the component can be colored is when the internal face is on the default material. In your model the internal faces are not on the default color, they are on the white color that gets imported.

So, delete the white color and let the places where it is used be replaced by the default color. Then all of your colored components will show correctly.

1 Like

Oh yeah. I’ve been super pleased with how SketchUp has dealt with files made by the simulations I run, which is why I was hoping the problems I was seeing in 2021 were fixable or were operator error (i.e. me doing something dumb)

@colin I am being slow today I think. Could you clarify what you meant? If I check “import materials” I don’t see any colours still. Or did you mean the generation of the dxf itself needs to be significantly reworked?

I would check those other two boxes as well, to reduce the number of edges and faces in the final imported geometry.

After it is imported, look at the Colors palette, Colors in Model, and you will see this:

Right-click on that second material, the white one, and choose Remove. When told that the material is being used, choose to replace it with the default material. Now your colors should show up.

@colin is the root problem an error in the way the dxf file is made? I ask because I regularly process 100+ files to generate 2d images, and the less I need to click the better.

As it could import with 2017 and the colors got assigned ok, there’s a good chance that when importing materials was added, that something wasn’t done quite right. I will mention it to the developers, so they can think about how to import real materials, but also convert the coloring to materials like was done with 2017.

Meanwhile, it is only one action per file to fix the problem. Can you confirm that the fix worked for you?

@colin can confirm the work around for 2021 you described shows the colours as the 2017 version did.

You’ve been a huge help. Thanks for taking the time to dig into this.

Not sure if it’s relevant or helpful but the scale issue could be an imperial to metric conversion problem. I say this because 2.54 is the conversion ratio from inches to meters. I get this problem all the time, even between formal CAD programs and have programmed myself to manually scale everything up. (which is not a great solution btw). If you have access to the export software, perhaps look at the units on export AND then on import into SU. If the 2021 ‘error’ of having “Coords out of range” exists in your 2018 version, then I suspect it’s because some detail is too small for SU (just a guess based on SU’s known dislike of modelling tiny details).

Dear Professor… I am fascinated by your work… why are you simulating forests in Sketchup?
Environmental Analysis ?