Import DXF Scale Not Correct (DXF File From Shape3D Software)

Please help, I have bug in SketchUp Pro 2021

  • SketchUp Pro 2021 can’t Import in right scale from DXF (the drawing result appears larger than the real scale)
  • DXF file obtained from shape3D software (export from Shape3D)
  • Shape3D is software to make Surfboard

Is there a solution for this problem?

This would NOT be a bug in SketchUp. When you import the .dxf into SketchUp did you choose the correct units in the Import Options panel?

You can resize the geometry of you know a specific length in the model. Open the imported component for editing. Use the Tape Measure tool and measure the known length making sure to click at both end points. Then type the correct distance and press Enter.

I’m already using the correct units, I have also used some units but the result still same like in the picture

I can’t resize because I don’t know the real size of the surfboard, in software Shape3D is only view the size on Top/Bottom. The DXF file from Shape3D can view the size of the surfboard curve.

You have the real size here

Your screenshot indicates that the file uses Millimeters. Your SketchUp screenshot indicates that you have used Inches or even Feet to import. The import unit setting is behind the Options button on the Import File dialog box.

1 Like

Share the dxf file with us.

WBM2_76 Master VARUNA_hollowplan skin 0.dxf (2.1 MB)

this is DXF file I used

Where’s the dxf for the whole board from your screen shot? Share that, too.

I can’t share that file, because the extension of the file is .s3dx.

I already use the unit in mm, but the result still same like my screenshoot

No you don’t. What units are chosen in your Model Info>Units dialog are irrelevant.
Open the Import File dialog. Select DWG/DXF as the file type. Push the Options button.

In the Options dialog, select Millimeters as the unit to be used. This has no connection to the Units dialog. Click OK
This is what I got when I imported using Millimeters. If you find that something is missing, try using a larger unit (Centimeters, Meters) and scaling the result down with the Scale tool.
DXF_Import.skp (327.2 KB)
(BTW, My first SketchUp forum question was about this same thing, about 20 years ago. The Options button is well hidden in plain sight.)

How you can show option menu? I don’t have option menu in my Sketchup Pro 2021.

First you have to select the file you want to import so SketchUp knows which options to show in the Options panel. Then to Options button will show at the bottom.

Follow the steps I showed you, select DWG/DXF as the import file type.

Thanks all problem solved