Importing .dxf file from a website Not sure why the size of the project is only a few mm? Am I doing something wrong?


#1

I downloaded a .dxf file from a website. Actually a group of .dxf files from someone’s project. I imported them successfully into SketchUp pro 2017. (my first time using a CAD program) I started to do some work on the files, then I noticed that the size of the part in the .dxf files were only 22mm across. I expected the part to be at least 5" across.

Is there something I’m doing wrong or is there something I"m missing? I tried another CAD program and got a similar measurement.

The files show a 1D part which was supposed to be laser cut. I wanted to make them 5mm thick and convert for 3D printing.

Any suggestions? Can anyone look at the files for me and give an opinion?

thanks!


#2

In the Import window click on Options and set the units to match the units in the CAD file.


#3

I’m not sure how to determine which units were used in the CAD file.

but when I change units in Options like you suggested, I get a change in the measurements.

Also - when I do the import, I see a box that says Makerbot Replicator 2x. what is that ?


#4

Do you know how big the thing is supposed to be? That would be a clue.

As for the box you see, that’s due to the fact that you’ve chosen the 3D Printing template. That thing gives you a sort of frame of reference for size but beyond that it is of no use. You could delete it from the model space or choose one of the other templates instead.


#5

I had someone with CAD expertise open up the .dxf files and provided the overall dimensions - They’re in inches.

so now I have the proper dimension to base the imports units on.

thanks for your suggestions.

Now I’m off to search how to add thickness to the parts for 3d printing, AND make the holes go though the part. I did see a youtube video that said I had select the hole, use the push pull tool to add 3d to the hole, then erase the 3d hole object. Seems like a round about way of doing it.


#6

It sounds like a whole lot of needless work to me. If the shape is flat and has through holes in it, erase the faces inside the holes and use Push/Pull to pull the face up to create the thickness.


#7

Thanks. I’ll have to figure out how to select the faces in the holes. Right now I’m having difficulty selecting anything in the shape, even to get the push pull tool to work.


#8

Perhaps you don’t even have faces yet. Trace one of the outside edges of the shape with the Line tool. Do you get a face? You could upload the SKP file as it is so we can take a look and give you proper guidance without guessing.


#9

I traced an outside edge with the line tool. the complete object turned white - does that indicate “a face”?

let me look up how to upload a file. I dont see any options in these email threads.


#10

basebottom to forum.skp (1.2 MB)

ok, found the upload icon!


#11

Yes. That’s a face. Select all of the geometry with a large selection box around it all, right click on it and choose Intersect Faces>With Model. Then you should be able to select the faces inside the holes and hit Delete to get rid of them.

As for uploading the SKP file, you need to go to the thread in the forum (not in your e-mail) and make a reply. Click the Upload button, 7th from the left above the message window, and attach the file.


#12

OK, that appeared to work nicely. I can rotate the object around and it appears that I see color through them now. thanks for the help! sure beats stumbling around.


#13

one more, with the push pull tool - can you set the thickness? I need to pull it to 5mm, and It’s hit and miss moving the mouse. I’m getting all over the place with the thickness number.


#14

Clic on the face with the Push/Pull tool and release the mouse. Move the cursor in the up direction, let go of the mouse and type 5mm. Hit Enter.

Time for you to look at the getting started videos. go to sketchUp.com and click on Learn.


#15

yep. tonights plan! thanks.


#16

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.