SURFBOARD importing DXF, missing faces?!

I have a 3D model of a surfboard that was created in Shape3d. The model was saved at the highest resolution that I could in Shape3d. Upon importing it into sketchup I receive this degenerate face issue and this is what the model looks like…

See the open faces and incomplete model? 3 open places total. Anyone know why?
Thank you,

Very likely you’re running into SketchUp’s inability to create very short line segments. While they can exist, SketchUp won’t create them. You might try importing the DXF at some larger scale than you are and then scale the model down afterward.

Out of curiosity, how will you use the SketchUp model after you’ve got it?

DaveR thanks for the info. Will give it a shot. How do I import it at a larger scale? I am doing this to ad the fin boxes for my DIY CNC router. Thanks again

In the import window, click on options and change the units to something larger. If your CAD file is in inches, change it to feet or to meters.