.DXF exporting makes object too large, not scale


#1

Hello, im trying to export the attached to .dxf, i selected export to 2D and then turned on 1.1 scaling, the object is 640 mm long but when exporting and selectingSketchup scale.skp (102.1 KB)
options its saving as 1291 mm.


#2

Look to the top menus.

• Camera > Standard Views > Top
• Camera > Parallel Projection


#3

When i switch to Parallel Projection, same issue, it says 1291 mm when the object is 640 mm.


#4

I just tried it… and Geo’s instructions work: the resultant DXF measures 640 mm.
Please set out exactly the steps you have taken to get to your problem DXF.
Doing Geo’s steps give the hoped for result - so you must be doing something differently…

In passing, why do you need a 2d DXF ?
Why not make a 3d one, where the idea of scaling AND the keeping of layering etc is much better ?


#5

You must apply both settings, not just Parallel Projection

Camera > Standard Views > Top and Camera > Parallel Projection


Sketchup scale.dxf (7.9 KB)


#6

Ok, so opened the file its 640mm long, did exactly as mentioned Camera > Standard Views > Top and Camera > Parallel Projection

Save Export 2D, options 1:1 scale in there it shows 1240MM instead of 640mm


#7

is basically a screen shot with vectors, if you want accurate scale you need to Export >> 3D with all the rest the same…

john


#8

I too was unable to export it to a wrong scale. What application are you using to open and check the DWG or DXF file? I used Autidesk Trueview 2019.
image


#9


#10

If i save and open in Sketchup; it shows the incorrect size.


#11

View: Top
Camera : Parallel Projection
Zoom Extents
Export


#12

@DoubleHelix

Hi Fred,

I don’t fully understand what you’re trying to demonstrate in the video.

Why do you un-check the Full Scale (1 : 1) box if you want to export at Full Scale?
Then, after un-checking the Full Scale box, you’re focusing on the Drawing Size fields.

It seems you believe the Drawing Size field indicates the actual size of the geometry. It does not.
The Drawing Size field merely indicates viewport size or ‘paper size’ when exporting at a certain scale.

If you want to export at Full Scale (1 : 1) then leave the checkmark in the Full Scale (1 : 1) box.
Notice when the Full Scale box is checked, the Drawing Size and Scale fields are grayed out.


#13

Hello, i was showing the mm is set to before saving, then saving it goins up to a larger number making the model larger, that’s been the issue the whole time, also the video was a walk through of my step by step


#14

Hello all, thanks for everyone’s input, i installed an .SVG conversion extension and it worked,