DWG lines are not straight and off when I import to SU2016


#1

Hello guys. I am new to the forum and I need some help. I import a dwg in SU and the lines are off. The units are the same when I import the file and the anti alias in openGL is set to x4. I don’t know what else to do to fix it.


#2

here is the DWG file https://ufile.io/w7pvm


#3

I’m in SU 2015 and have no issues. I can’t speak to any other version, but in 2015 I just used the File>Import command, and it didn’t even give me any options to change settings, just imported it and everything was perfect.


#4

can you please save it as a sketchup file and send it back to me so I can check if its ok? @MobelDesign


#5

I’m still hoping someone can help you with why it isn’t working for you; I don’t know enough to diagnose myself.

Are you using the File>Import method?

dwg_import.skp (38.5 KB)


#6

Yes. I do everything by the book and I don’t know what else to do. It’s so furstrating. Thank you for the model. I will let you know if it worked.


#7

@MobelDesign you model worked fine. No crooked lines. At least I can work now. Thank you so much.


#8

To me it looks like you are importing the file with a way smaller import unit (see behind the Options button on the Import dialog box) than the one it was created with, like millimeters vs. meters, or that the geometry in the file is very far from the AutoCad origin, and you are leaving the “preserve drawing origin” box checked.


#9

This is most likely an error from the import being too small. Probably it’s modeled in meters and you imported it as mm. When vertices in SketchUp gets too close they are merged into one which is exactly what happens here.


#10

I’ll go with @Anssi . Long distance causes weird graphic issues just like decribed.


#11

Turns out @eneroth3 is more likely right (@Anssi mentioned it too, actually)

First, notice the axes in the original post – I realize that @stelios_m could have moved the geometry to the origin, but from my further investigation, I think the units was more likely the problem. In the first screenshot I imported as millimeters, and got very similar results to original post:


Then I imported with larger units, but ticked preserve model origin, and there was no issue.


#12

This is really helpful guys. Thank you so much. I will let you know if it worked when I get my hands on my ‘‘work’’ pc. I think that indeed my dwg is done in meters and I imported it in sketchup in mm. I remember doing that :frowning:


#13

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.