Strange whirly lines from dwg import


#1

Hi!

When I try to import some of my dwg and dxf files, lines and circles get whirly and look strange.

After importing these files, everything I draw in the skp-file also look whirly and unprecise. I also can’t seem to snap to anything correctly.

Anyone know what could be the probelm here?

Any help appriciated.


#2

Hi, can you upload a screenshot or that file?


#3

I’m going to guess that units in the file doesn’t match the units you have selected from import. I’ve seen some really weird things when that happens.


#4

Is the DWG file very large, or far from the SketchUp model origin? Do they contain some digital mapping data?

When importing check the settings behind the Options button on the Import File dialog box. In most cases, you should uncheck the “Preserve drawing origin” box and check that the import unit is set to the one used in the DWG. The default import unit is Feet, so if you are importing a file that uses millimeters, the result is 254 times too big.

Anssi


#5

Unchecking the “Preserve drawing origin” box worked!
Big thanks!!


#6

Unchecking the ‘preserve origin’ box has not resolved it for me. I have been imported DWGs before and not had this trouble. Splines have also gone all funny too.


#7

Have you set the correct unit for the imported file? It’s not detected automatically so you need to make sure the Import settings match the DWG you import.

Alos, beware that blocks’ own internal origin can also cause them to act odd. If you see this strange jitter only in some block (which are imported as components into SU) then try to either correct the block origin in the DWG or explode the components in SU.


#8

Yeap - well AutoCad has Type - Decimal, Precision - 0.0000 and Insertion Scale - Unitless.

The issue is not affected by blocks. Even drawing new circles produces the same jitter lines. Open to any other suggestions.


#9

while looking for something else today I found this site which seems to have a lot that would also be useful for ‘exporting’ to SU from Autocad…
I don’t have autocad, but found it interesting all the same…
john