DWG imports to SketchUp are a mess and need exploding

Hi, I have this continuous issue where if I import a revit dwg export into sketchup it comes in an absolute mess. As you orbit around the model it all flickers in random places. I have to go through each and every component and explode and re-group. Is this a common issue and can anything be done on either end to prevent this?

thanks :slight_smile:

Check your model detail and export settings in Revit. If I remember right, the finest setting results in the internal structure of wall types being exported. The flickering you see would be caused by z-fighting when faces either coincide or are very near to each other.

Hi Anssi, thanks for you reply! I usually receive the models from people as dwg’s so im not usually the one exporting it, but im trying to find out so I can ask them to make the changes. what do you mean by finest setting results?


I don’t have Revit at the moment, but it has three settings for model level of detail. For export to SketchUp use I would perhaps recommend the coarsest setting.

In the past I once saw a model showing flickering of edges.

The model was very far from the axes origin.

After moving it to the origin, the flickering stoped.

1 Like

Ahh, I forgot. In Revit, if the model is geolocated, you have the option of exporting using the model’s local coordinates or the coordinates that have been input in the Survey Point. The latter might place the model very, very far from the origin. If possible, ask for an export that uses project coordinates instead of survey coordinates.

1 Like

Hi, thank you so much the axis was the problem after all! It all works now the model is exported from the correct coordinates.

Thanks for both of your help!