Geometry moving/ distorting when inside components; can't trace properly over existing geometry

Hi everyone,

I’m trying to make a SU model of a house by using dwg. elevations with the floorplan as an accurate template, to save time. Has worked for me in the past, but somehow not with these new drawings!

Not sure if this is a Revit/ GIS-related issue. The original dwg. file is extremely elaborate.

The geometry seems to flicker and move like a cartoon when inside groups/components - see the floor in my model to see what I mean. Also, when I try to trace over lines, it doesn’t snap to where I want it to, for some reason?

And yes, I’ve set the origin to 0,0,0 & even tried Axes Tools to reset the axes on all groups, which has helped but it still doesn’t fix it.

Thanks,

In the file you shared, the axes and the model are no where near (0,0,0). You’re almost 400 Km away. Right click on an axis line and choose Reset. Then move the model to the origin.

2 Likes

Here I’ve reset the axes, moved the model close to the origin, fixed incorrect tag usage, and purged the unused stuff from your model.
Screenshot - 10_6_2022 , 5_32_41 PM

Screenshot - 10_6_2022 , 5_32_57 PM

Forum question.skp (5.3 MB)

Thank you @ DaveR!! As usual, you get things sorted. Such a simple mistake too.

Which extension do you use to purge unused stuff from the model?

Also, when I orbit, my model seems to erase at certain angles… Is there a workaround for this?

Hi Dave,

Why is it so important that the model is at the origin? Surely it is nothing more than an offset calculation?
I struggle as I need the original geometery to be in the file AND the modified geometery so I always end up with a model 20m above the origin. If there are variations, I can have two/three models above the origin.

If the model (or part of it) located long distance from origin, it is causing flickering, clipping and difficulties to catch the inferences.
20m is totally different than 400km mentioned above. It also depends on a real size of your model. If you are modelling a desk, a room with a couple of meters, or a garden with couple of 100meters sizes, 20m is not “long”, but 400km is huge.

Take a look also on:
https://help.sketchup.com/en/sketchup/clipping-and-missing-faces

1 Like

Thanks for answering, I have had issues in the past on very large models as there were a few versions and they ended up a long way away from the origin.

In my opinion is better to have the different versions saved to different files, instead of one “big”.
You can open these files in a separate Sketchup instance. You can drag & drop in between or copy- paste (paste in place!!) from one to other(s)… if you have two (or more) monitors even more easy to compare… etc. :innocent:

1 Like

Purging unused can be done via Window>Model Info>Statistics. I use TIG’s Purge All because it gives the report I showed.

Is that in your copy of the file or the version I uploaded? If your file, did you move the model to the origin after resetting the axes? What you are seeing is called clipping and can happen when you have something at a huge distance from the rest of the model. Perhaps you missed moving something. As for a workaround, there isn’t one. You just need to clean up the model and make sure there’s nothing hanging out there in space.

1 Like

Hi Graeme,

Looks like @dezmo has answered your questions. A note about your multiple versions of a project, though. Since there will be some parts of the project that remain the same, you could use tags, tag folders, and scenes to show the different options instead of spreading out a bunch of copies across the countryside.

1 Like