DWG import failing in 2023 version

Hi there. I am trying to import a DWG file into SU Pro 2023 but it is failing. I don’t normally have a problem. I work on CAD in Vectorworks and then export to DWG. I then import the new DWG into my SU. In this instance, I am repeatedly getting the message “Import failed”. Thank you for your help!

could the DWG be too recent ?

Usually with this type of software, they tend to have a translating tool working a few years late. SU23 wouldn’t be able to open the lastest DWG2023 standard, but would open a bit older ones.

Capture d’écran 2023-08-05 à 11.38.39

The exporter can go up to 2018 (ni idea if there is a new standard since 2018), I wouldn’t be surprised if the importer was limited to 2018 as well.

do you have any option in vectorworks, while exporting, to adjust the compatibility (year) of your DWG ?

1 Like

Can you post a DWG that fails to load? Do you get the DWGs you import all from the same source? Do you get them from people who use AutoCad extensions like Civil or Architecture?

Version 2018 DWG format is the newest, it is the one that Autocad 2024 still uses.

1 Like

Is this a “vanilla” AutoCAD file or an AutoCAD Architecture dwg?

Thanks for all of your comments - I do appreciate it.

I tried different versions for the DWG format but it didn’t seem to make any difference.

I’ve got it to import this morning by using the SketchUp menu (File - Import), rather than just dragging the DWG file into the model, which has always worked in the past. Maybe just a bug but I guess I will stick with that route in future.

Thank you again for all of your help and comments :slight_smile:

Sketchup please can you reply, since having SU Pro 2023 for months I have been unable to import any file type that is supported from any year. I run mine on MAC, and before anyone comments, change the save type year. that’s not the problem.

My solution is to retain my 2022 version, import any file that is supported, (and it always works in 2022) and then copy it from 2022 to 2023. This is a fundamental bug in the latest version and there needs to be some sort of hot fix asap.

Did you install SketchUp correctly or are you running it from the downloaded disk image file? This is the most common reason for failing importers or exporters with the Mac version.
Or are you running an unsupported version of MacOS? There was a change in supported OS versions from 2022 to 2023.

I installed it like the 5 previous version,

I am running an official Mac OS 13.4 I think

So should I re-download ? But I have installed updates and that makes appear it’s installed correctly ?

There is a problem in 2023 to do with drag and drop of DWG. We do have that fixed, and the fix should be in the next update we release. I can’t tell you when that update will be posted.

1 Like

I’m a new user suffering this issue. I have no advanced knowledge to figure out a workaround. This is a basic file and the reason i bought sketchup.
Can you please advice how i can open dwg file reliably?

Go to file, import and select the dwg file you want to open.

thanks… i have been doing this but it’s not working. The app crashed the last few times, though it has just worked now.

Thank you, Colin.

I think my earlier reply was before 2023.1 was released. One of the fixes in that update was to do with dragging DWG/DXF files into a SketchUp model was failing on Mac. If you did get the update already you could give it a try.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.