SketchUp Pro Trial .DWG Import Issues


#1

Hi, I’ve got 11 days remaining on my SketchUp 2016 Pro Trial and this morning I’ve tried to import a .dwg file but it just comes up with the error message ‘import failed’. I’ve also tried with .dxf which comes up with the same error. I was under the impression that the Pro Trial should be able to do this or am I wrong?

Thanks,

Jo


#2

Maybe there’s something wrong with the file you’re trying to import or the settings you’ve selected under Options in the Import window?


#3

Thanks Dave,

I’ve had a play with some of the layers and saved as an AutoCad 2013 compatible file and I’ve got it to work now.

Jo


#4

We can infer from the DWG Exporter supporting only up to AutoCAD v2013, that likely that is also maximum version that the SketchUp Importer supports (as of SketchUp 2016.)

SketchUp Help: Importing and Exporting CAD Files says:

Before you import a CAD file into SketchUp Pro, it’s helpful to know what CAD elements SketchUp Pro can and can’t import.

When you take a few steps to check and prepare your CAD file before import, you can make sure all the data you need imports into SketchUp Pro and streamline the import process.

So SketchUp Help: Importing and Exporting CAD Files is recommended reading.


#5

Actually that is the newest AutoCad file format. AutoCad versions 2014, 2015 and 2016 are still using that. We’ll see what the next Autodesk upgrade cycle brings.

Anssi


#6

Ok, perhaps it was some unsupported ACAD objects.

FYI, it has been logged that the “Import failed” message is worthless and we need better explanation of what caused the failure, to be displayed in the error dialog.


#7

Yes. The way the importer fails is not very graceful. I remember that sometimes the importer has crashed the whole application.

Anssi


#8

I had the same issue, then I saved my CAD file to as a 2013 file, and it worked. Hope this helps.


#9

2 years, 4 months ago … by the original thread starter …

:roll_eyes:


#10

Thanks for sharing, nice post! Post really provice useful information!