DWG Export Issue


#1

I’ve run into an odd problem exporting DWG from SU2014. For example (attached) when exporting a RC plan, if I’m zoomed out on the plan, I get dashed hidden lines inside of circular pipe. If I zoom in on the same elements and export, hidden lines are display correctly. I’ve been trying all sorts of things and no luck. Any thoughts would be appreciated, thanks.


#2

Hello pois,

The image you posted is rather dark.
Here’s an enhanced version to aid those who wish to help.
Have you looked under the Options button in the Export Dialog?

-Geo


#3

Thanks Geo. I should have realized how hard it was to see the problem. But I’m vexed…
The only difference in output between dwg output on left to right was the “zoom distance” between the two outputs, i.e. full plan zoom out and zoom in on plan before outputting in SU.

As mentioned, it seems to effect only tube shapes, extruded circles and such…???

P


#4

Hello pois,

It would help us help you if you could better describe what you’re trying to accomplish.
Sharing the model would help immensely as well, that is, if you’re at liberty to do so.
Save it in the state just as you are about to export.

You say you’re exporting “a RC plan” to DWG.
What does “RC plan” mean to you? To me, it usually means ‘Reflected Ceiling plan’.
I gather from the image of mechanical things that’s not the case here.

Are you exporting 2D or 3D DWG?
Is the camera set to Perspective or Parallel Projection?
Have you looked under the Options button in whichever 2D/3D Export Dialog?
Relate to us the options settings you used. A screenshot is easiest here.

-Geo


#5

Hi

I’m exporting a “Reflected Ceiling Plan” to DWG as to create backgrounds for consultants to work upon. I’m using parallel projection, and all export options are off except scale 1:1 for acad’s model space.

Now, here’s an interesting result from a test from a few minutes ago. I back saved the file to SU V8 and then opened it in SU8. I used all the same export options to DWG other than acad version 2010. The resulting DWG file did not exhibit the same hidden line export problems from SU2014. Albeit, it took way more time for the export but result was perfect. Seems like some sort of DWG export issue in 2014…?

Thanks,

P


#6

Good to hear you have a successful export, by whatever means.
And thanks for testing and relating the results.
@tt_su may want to have a look at this.

-Geo


#7

Good to have a workaround, but very, very slow via SU8. Still a very weird problem.

Thanks again Geo,

P


#8

I couldn’t quite understand what you meant by “dashed hidden lines”. SketchUp vector export only exports continuous lines. People have been reporting problems with 2D hidden-line images and DWG files exporting as wireframe, showing unwanted edges that should be hidden. Is this what you are seeing? It is an OpenGL display driver problem and can be corrected either by upgrading the driver software to a version with better OpenGL support, or by turning off OpenGL Hardware Acceleration (Window menu>Preferences>OpenGL) and restarting SketchUp before printing or exporting.

Anssi


#9

Hi Anssi

SU should export continuous lines, but this issue I’m describing indicates something is wrong with the 2014 DWG export function. See attached screen shot. You can see where SU is outputting dashed lines of things behind a circular round tube.

Regards,

P


#10

Demands upon the graphics subsystem tend to increase with every new (faster) version of SU.
Updating the graphics driver may (usually) resolve the problem.

Turning off OpenGL Hardware Acceleration, as Anssi recommended, takes the GPU out of the loop.
Perhaps try that first and let us know if it resolves the problem in SU 2014.

Resources

.

Graphics Issues — SketchUp Sage Site

-Geo


#11

Hey geo,

I just gave it a try but the problem remains. Darn, it was a good idea.

P


#12

Can you post a SketchUp model that gives you this problem? Perhaps together with the defective DWG file?

Anssi


#13

The entire model is too big, but I can try to pull it out and put in it’s own file.

Thanks Anssi,

P


#14

Hi,

I’ve attached 3 files for your review.
SU test file with isolated element
SU DWG export file - exported zoomed out
SU DWG export file - exported zoomed close

DWG files exported as acad version 2013, SU set to parallel projection.

You’ll notice the problem when comparing the zoomed out DWG vs zoomed in DWG in acad.

Thanks

P
SU test files.zip (1.6 MB)


#15

I get similar export results

Just some comments on your model. I don’t know if they are the reason for the export behaviour.
Was this imported from some other application (it has some non-SketchUp-like features)?

  • the round tube members of the tubular frame have very many segments. The default 24 might be enough at this level of detail
  • the parts of the truss are separate objects placed partly inside each other, but they do not intersect - so the CAD export doesn’t have the intersection lines either.
  • what looks like dashed lines in your exports are parts pf the profiles of the members of the tubular structure. It might be due to the very small size of the segments of the tubes that SketchUp struggles with the calculations of what should be behind what. A partial export has less data to process, hence the better results.

I would perhaps try to get rid of the overlapping parts of the model, either using the Intersect With Model tool, or the Boolean operations in the Pro version. Remodeling the tubular parts with fewer segments might also help.

Anssi


#16

I’m interested to learn if they come from the 3D Warehouse.

-Geo


#17

Hi All,

Sorry for the slow response. The test model I attached was not from the warehouse. I think I got that one from the Thomas Truss site. I did download a flat truss from the warehouse that exhibited similar results. Also, a tube I built for another assembly also showed similar results.

But…

I think you’re on the right track about the source of the problem. All tubes had somewhat high segment counts in their circular constructions.

I think it’s fair to say lower segment geometry on tubes doesn’t exhibit the problem. The attached image is a circular tube (low segments) intersected by horizontal tubes. When exported to acad, the tube does not show hidden geometry,

The interesting thing is that SU V8 dwg exports did not exhibit this issue.

Thanks for all the input and help,

P