Dragging selection rectangle, hangs up, crashes

Hi, I have file where the selection tool causes crashes and other weird behavior. When I drag out a selection rectangle on part of group I want to select, it draws a solid rectangle but nothing turns blue, then with the next click it either crashes or other surfaces dissapear. When I reopen the file I get an alert that all problems have been fixed but they continue
Does not seem to be happening with other files. I just updated version 21.0.392 to see if that helped and it did not. I am on a new Macbook Pro running Big Sur
Got any ideas?

Adding the file here so someone can check it would help.

Thanks. It is plan for remodel of a much remodeled cabin.
Also, I am using a Logitech MX Master 3 for Mac mouse.
Would appreciate any ideas on how to fix it.

Chip & Sarah Model New.skp (9.8 MB)

I’ve had a quick look at your model. It opens without problems in both SU 2018.1 (on Mac Mojave) and the latest SU2021, and I have no problem dragging selection rectangles.

The most likely explanation of your problem is that your graphics driver has problems, but that is unusual on a Mac. However, you have a basic Intel graphics chip, which might possibly be the source of your issues. The only way I know of to update the graphics driver is to update Mac OS X, and you have already done that, you say. (Your profile still says you are running SU 2018 and High Sierra, by the way. If you stick with 2021 and Big Sur, please update it.)

Can you downgrade the OS to the version before? Big Sur has caused some problems for SU. If not, can you check you have the latest version of SU 2021 (you probably have, if you’ve just installed it. For Mac, it’s 2021.0.392 (Check from the Sketchup menu, About Sketchup.) And the latest version of Big Sur?

If other models don’t have this problem, It might be worth your while trying to open your model, use Cmnd A to Select All, and copy that to the clipboard. Open a new file and use Edit/Paste in Place to start a new copy of the model. Save it with a new name, and see if that helps. Close the original.

For what it’s worth, there are a number of common beginner modelling errors in your model, but they shouldn’t cause a crash. They are however worth fixing before you go further.

  1. First, you have assigned non-default Layers (Tags in SU 2020 and 2021) to some edges and faces. Possibly you exploded a component or group to which you had assigned a non-default layer or tag. That assigns the layer to the edges and faces after they are exploded. Open for editing each group or component in the model in turn, select all inside the group, and set the tag to Untagged in Entity Info. If all the edges and faces are already assigned to Untagged, then it will show in the Tag line in Entity Info already, but if that line is blank, some have another non-default tag assigned.

Leave Layer0/Untagged as the default layer/tag (which it is, correctly, in the file you uploaded). Assign ONLY Layer0 or Untagged to raw geometry - edges and faces. That will happen by default if the little pencil icon at the right in the Tags window is on the Untagged line. (It’s a radio button on the left, in versions of SU before 2020.)

I’ve run the CheckUp 3 plugin Geometry to Layer0 plugin to do that automatically.

  1. When I view your model with View/Face style/Monochrome, and Roof and Walls tags turned on, I see some reversed faces.

Click on each blue/grey (reversed) face in turn (you may have to open a group for editing first) and select Reverse Faces to fix this.

  1. Your plan and elevation scenes are not set in Parallel Projection, top and front views, but in perspective, and not from quite the right direction.

In the Plan scene, go to the Camera menu, and select Parallel projection, then Camera/Standard views/Top (or press Cmnd+1 on Mac). Right click on the Plan scene tab, and click Update to save that change.

Similarly, in the Elevation scene, again choose Camera/Parallel projection, then Camera/Standard views/Front (shortcut Cmnd+3).

You could if you wish similarly set up a Side Elevation scene.

Use more components for separate parts of your model. Any geometry that isn’t in a component will ‘stick’ to any other geometry that you draw, even if it is on a Layer or Tag that is turned off. And geometry within one component or group will stick to all other geometry in that same component or group.

Hope the copy/paste into a new model fixes the recurring graphics problems. If not, perhaps someone else more knowledgable than I can help with the graphics chip driver problem.

Here’s my minor update to your model.
Chip & Sarah Model New.skp (9.7 MB)

PS. If you haven’t already, watch the SketchUp Fundamentals series of videos on learn.sketchup.com.

And there’s a new post on the forum here, Watch This Before You Get Started With SketchUp (2021 Update)

which might be worth your while to view too.

Most likely the problem is that you have to open a Group or Component for edit before you can select anything inside it. But that shouldn’t cause a crash. Are you sending in the BugSplat reports?

Thank you for walking me through possible solutions. A wealth of input and much appreciated. Will check back when I have explored your suggestions. Regards.

Well, by golly, opened up your revision and things are working fine. Still need to review comments to find where I went wrong. Very unsettling.
Thanks very much for the comments.

Very glad to hear that. Happy modelling in future.

Well, I am back with different model and same problem, maybe worse. Just starting a major project and very unsettling to be having issues. A few hours into this I started having the same problem with the selection rectangle hanging up and possibly crashing. Now some new glitches that caused the whole OS to crash. Getting white flickers, screen goes white for fraction of second. Shadows won’t turn off. Also, Layout refresh of viewport changes is taking 15 seconds or more. Don’t know whether to call Apple or Trimble.
I will load the file.
Be great to sort this out, thanks.
R&R New Draft.skp (3.3 MB)

Also, updated my profile here with current system data.

Your profile is still showing SU 2018 and OS v13.5 (High Sierra) - have you reverted to older versions of both? You said earlier you had upgraded to SU 2021 and Big Sur.

Your model ‘behaves’ in my SU2021 running on Mojave.

I still think the most likely problem is that your graphics card and/or its drivers aren’t quite up to running SU. But on a Mac there’s not a lot you can do about that as far as I know, short of buying a new machine (which you’ve just done). But others more knowledgeable than I am may have other things to suggest. (I just use Macs, don’t have deep technical knowledge about them.)

Do you have any other machine (Mac or Windows) you could use to run SU instead, just to see if it your problem derives from the model, or your machine?

Other points I noticed, but none that would cause the crashes you are experiencing, just a mattering of modelling practice you could improve.

You have some unused components in your model. Unless you know you are going to want them later, you could purge the model, to clean it up.

And there are a couple of small problems with your roof groups - the main house roof has missing end faces, and one of the garage roofs has reversed faces at the end. That’s easier to see when I revert to a simple Default style, or switch to View/Face style/Monochrome.

While modelling, you would find it easier to see any modelling errors in such a simple style, though I like the style you have used, for presentation purposes and overall appearance.

You should give your scenes more meaningful names - while you are modelling, you may remember that Scene 10 is a plan view (this time correctly in Parallel projection), but two months down the line you probably won’t remember.

Some of your groups (for example the one on the Atrium tag) are rather large collections of loose geometry. Better practice is to subdivide it into smaller components. Makes later editing much easier, and also easier to generate lists of the different window and door types and sizes you will need when it comes to construction.

But none of these comments get to the heart of the fundamental problem you have with your machine.

Have you tried one thing I suggested before? Turn on all Layers or Tags, unhide any hidden geometry, and Select All, then copy to clipboard and paste in place into a new model.

I can’t see anything fundamentally wrong with the model - it opens and loads normally, shows no graphics glitches on my machine, isn’t overly large, and throws no errors either on opening, or when I run Window/Model info/Statistics/Fix problems.

Although on the whole they are pretty solid, Macs can have hardware failures. Have you run or had an Apple tech run diagnostics on yours?

Thanks, was going to call Apple tech folk and see if they know what might be happening. Does Trimble have a tech advisory number?
Getting to Apple tech in not easy where I live, Maybe Aspen. When you say have I run diagnostics, do you mean that is something I could do myself?

Okay, so have not tried the copy and paste to new yet. That worked last time for a while, considerable work to get set back up as I recall. I am saving frequently and saving copies, but the uncertainty is hard to handle. Twice the whole syatem crashed so its got to be something beyond my mistakes. And while my technique may be flawed, have done scores of residential plans sets
Does Trimble have a tech line?
Not sure of the next step here, have a lot of work lined up.
And thank very much for looking it over

Well, new wonders! Right now the selection rectangle is working for a while, but new weird effect is happening, see photos. Is that a symptom you recognize.

I’ve not seen that myself, but it seems typical of what on Windows would be graphics card/driver problems. Sorry, I’m out of my depth here in terms of what to do about it.

Thanks John. Does Trimble have a tech support number? Surely they would have some knowledge about the issue. Unless, as someone suggested, it is a hardware problem in my new machine.