Download Sketchup 2021.0

Where can I download SketchUp 2021.0, I want to reinstall SketchUp 2021.0. But I can only download 2021.1

1 Like

Be quick,
Still has 2021.0
I believe

What is the reason to reinstall 2021.0? If 2021.0.1 would do as well, I made this link:

2021.1 has some useful Mac specific fixes in it.

Just to test if a bug also happen in 2021.0 or is new in 2021.1
But it’s not 2021.1 which creates the crash, but it’s 2021.x on Big Sur on a Mac with a touchbar, no touchbar no crash, the error log also indicated the touchbar.

Is it the presence of a Touch Bar that matters, or the use of the Touch Bar?

presence, not the use.

Crash(*) happen when using execute_script on a webdialog in Ruby (in one case), but only on Big Sur and with the presence of a touchbar. Not on Cataline with touchbar, or Big Sur without touchbar.

(*) We workaround the crash by not doing the execute_script anymore in this case.

One of my favorite plugins - Ftattery has also stopped working with 2021.1. SketchUp just freezes. Worked fine with 2021.0

That is strange. 21.1 does have an updated CEF in it, and that may be relevant. I will check with the developers.

Is it calling a legacy WebKit thing because of how you call it, or how SketchUp passes it on?

I don’t really know how to use the ‘Flattery’ extension, but what I tried seemed to work in 2021.1, though a couple of times something showed in the Ruby Console to tell me I was doing something wrong. What fails for you?

SketchUp freezes the moment I select the unwrap tool. After 10+ minutes does not work still. Haven’t tested if any other extensions might be causing this problem. The only change has been the SU 2021.1 uodate.