Disabling Intel to Force NVIDIA Graphics, causing Screen Dimming

nvidia
graphics
graphicscard
blankscreen

#1

Hi everyone,
I recently purchased Sketchup Pro 2018 and went to open the program only to find the drawing screen blank, like I tried to draw on it and nothing showed up. I contacted support and the only thing that worked was disabling my Intel graphics card to force the program to use my NVIDIA GeForce 940MX graphics card. (We tried other settings to have Sketchup use this processor, but none of them worked so we literally had to disable the Intel one to get it to work). I was excited thinking it was fixed, but then found that if my computer rested for a few minutes, the screen would dim and when I came back, there was no way to get the brightness to come back. By disabling the Intel graphics card, all brightness settings are lost and I cannot control them using the keyboard or going into my control panel or anything. I have to restart my computer to get the normal brightness back. I’ve read a lot of forums about turning off adaptive brightness on the Intel card, which I did, but I don’t see any settings like this for NVIDIA (considering its when I’m using the NVIDIA graphics card that this is happening). I’ve also gone under my control panel to change the battery settings to prevent the dimming. Not sure where else to look.

All of my graphics cards are up to date, I just updated them within the last week and I check daily to see if there are new ones available. When I told Sketchup support about this follow up problem, they just told me to update my graphics drivers (this seems to be their response for everything), which isn’t the issue. It seems really ridiculous to me that I have to completely disable one of my drivers everytime I want to use sketchup, and then enable it every time I want to do regular work without my computer screen going dim.

Is there any other way to get Sketchup to run properly without disabling the Intel card? If not, are there any other settings I can check to keep my screen from dimming?

Any help is appreciated. Thanks!


#2

@Shaleesa_Mize, Hi, you have a similar setup as me. I have not had to disable my Intel GPU to use SketchUp Pro, so a couple of questions: which version of Win 10 are you using, which Intel CPU do you have, who is your computer made by? Best.


#3

I’m assuming that as a part of your initial troubleshooting you tried using the Nvidia control panel to force SU to use the discrete card. But just in case…

There also might be a setting in your BIOS to disable adaptive brightness.


#4

Thanks for the response Lindsey.
I bought an HP Pavilion last November. It shows Intel Core i7-8550U CPU @1.8 GHz and also says 1.99 GHz next to it. I’m running Windows 10 Pro.


#5

Hi Derek, thanks for your response. Yes we tried both of these things. I tried using the NVIDIA processor for global settings as well as in individual program settings for Trimble Sketchup. In the NVIDIA control panel, we also tried adjusting “use my preference emphasizing…” from quality to performance. I would apply then restart my computer after each change to see if it worked. No such luck.

The crazy part is, when I open Sketchup and go to preferences > Open GL > Graphics Card Details, it actually shows the NVIDIA GEForce graphic card being set. We tried enabling and disabling “use fast feedback” which didn’t seem to make a difference either way. I also tried to uninstall and reinstall sketchup twice.

I’m not sure what BIOS is, but here is how I disabled adaptive brightness (maybe it’s the same thing). Control Panel > Hardware and Sound > Power Options > change plan settings > advanced power settings > display > and then disabled adaptive brightness for both battery and plugged in. If there is somewhere else to do this, let me know!


#6

The BIOS is the firmware that loads when you first boot your computer before you get to the OS. You’ll have to consult the docs that came with your laptop to see how to access it but it’s usually pressing F2 or F11 or ESC or something while it’s booting and you can get to a text screen where you can change how your machine boots. I don’t have an HP so I can’t tell you exactly what to do here. Be careful in there and only change things you understand.

That said there also might be a setting in the BIOS to disable your Intel graphics card. We have had to use that for some Dell models we have. Dell used to call it Optimus. Thinkpads are ‘switchable graphics’. Not sure what HP is or if you can even do it. Hopefully someone else has a similar model laptop and can advise. Good luck.


#7

I’ll look into that. If the adaptive brightness settings are in there, then that could help. I don’t really love the idea of having to keep one card disabled, although I’m not sure if it makes a difference in the big scheme of things about how my computer runs (besides the brightness issue I have).

Just seems like a strange thing to do to get a program to run properly, especially considering I bought this computer specifically for architecture and design programs. Hm.


#8

I do not think I can be of much more assistance then from what has been posted in this thread. With your set up being HP and mine Lenovo, I believe the settings will be quite different to manipulate. Good luck.


#9

Thanks anyway, Lindsey.

Sketchup Support has been awful. They write me back maybe every 2-3 days so this has been ongoing for weeks now. I’m working with a technician today that I’m paying for to pick up Sketchup Support’s lack of help. It love spending $700 just to have a product not work. It’s just great :wink:


#11

It is not Trimble’s (SketchUp’s) fault. This has been an issue caused by a combination of Windows 10, display drivers and power management utilities going on nearly 2.5 years.

A simple search of the internet shows many other people have this issue and they do not even run SketchUp.

It is not fair (despite your frustration) to put the financial burden upon a company (Trimble) that is not responsible (nor has the ability) to fix issues caused by other company’s (Microsoft, Intel and Hewlett-Packard) products.


(1) In the HP forums is a post from 2015 giving a workaround (to use Hibernate instead of Sleep) …


(2) … in another forum an HP All-in-One user reported that a BIOS (firmware) update solved the issue.
He indicated that the BIOS should have been updated before Win10 was installed, but wasn’t in his case.
Have your technician check the HP Support site for a BIOS update specific the your computer model.


(3) Still another HP user found that after some Win10 update his “Generic PnP Monitor” in Device Manager was set to disabled. Enabling it then reboot (or cycling through disable, reboot, enable, reboot) solved some internal conflict and the dimming went away.


#12

Well it isn’t my computer, it IS sketchup. I never had this problem before Sketchup was installed (which if you read the post it says the whole sketchup viewer wouldn’t even show up, despite my bios and drivers etc being updated). You are mistaking the problem I had for adaptive brightness on the display issues (which yes, was a common HP problem I found in many forums whether people used sketchup or not). That was not the problem I had.

My technician finally figured out the problem. Despite sketchup telling me to update my drivers, the technician actually had to revert them to an older version. They said as new drivers come out or get updated, it is the responsibility of the software companies to create “patches” for their programs so they run properly. Sketchup obviously has not done that. The graphics cards that I have and everything with my computer was selected to be compatible and run sketchup and other architectural programs with ease. The fact that I have to revert to an older version of my graphics or disable even a basic driver to run sketchup is pretty sad.

Whether you agree with all that or not, I don’t really care. The bottom line is I paid a lot of money only to get ■■■■ customer service from the VERY beginning in resolving the issue. The first time I even contacted them, I don’t think I got a response for almost a week. Really nice when your daily job depends on the accessibility of software like this.


#13

Predating the OP’s installation of SketchUp (for years) is the prominent warning on
the SketchUp Hardware and Software Requirements page …

:information_source: SketchUp’s performance relies heavily on the graphics card driver and its ability to support OpenGL 3.0 or higher. To test your graphics card’s compatibility, please download and run the SketchUp 2017 Checkup application. Historically, people have seen problems with Intel-based cards with SketchUp. We don’t recommend using these graphics cards with SketchUp at this time.

This page also recommends …

  • 3D-class video card with 512MB of memory or higher and supports hardware acceleration. Please ensure that the video card driver supports OpenGL version 3.0 or higher and is up to date.

The “up to date” link brings up the “How can I update my computer’s graphics driver?” help article, which also clearly says (after the recommendations for latest driver and OEM weblinks) …

If you upgraded your driver to resolve a display issue, and it didn’t resolve the issue, you may consider installing an older driver for your graphics card instead. Older drivers may be available online or in a resource CD that came with your computer. NVIDIA, for example, offers a driver archive.

So, the SketchUp Help Center actually does have the correct advice.

The OP continues referring to the 3rd party technician …

This statement is UNTRUE ! Software development and distribution does not work this way.

Tens of thousands of software products cannot recompile and redistribute their applications each time a new bugged device driver is released.

If a technician actually said this, then they are either misleading you or they are incompetent about the topic of software development.

Software and firmware development does not seek to force fixes down at all the leaves of the distribution tree. The driver is one of the root nodes. That is where you need to make the fixes. It makes no sense to break all the software using the driver out in the field, and expect the using software to scramble and accommodate bugs in each and every driver release.

When we stop to realize just how many graphics devices there are, and how many more versions of device drivers have been released for these devices, … we can know just how ludicrous such a statement must be that software need adjust to every driver version.

( Ref, see: https://www.videocardbenchmark.net/ for a list of video cards.)

Driver version rollbacks are quite common (and not just with regard to SketchUp.) We’ve recommended driver rollbacks many times here in this forum, sometimes in regard to 3rd party rendering applications.

And again, this has nothing to do with SketchUp. (Search the internet and you’ll find users of other software often must rollback drivers as well.)

The fact that the latest device driver from an original equipment manufacturer introduced bugs in attempts to fix other bugs, is not something any software vendor can control or mitigate. And it is not anything new. It always has happened, and likely will continue.

As an example, Nvidia may release several GeForce video driver versions per month. It is very expensive for major application vendors to recompile and push out updated versions. (SketchUp has 12 language builds for OSX and Windows. That’s 24 installer builds.) Software vendors cannot do this several times a month, and anymore than a few times a year is not economical.

It is well know that since SketchUp switched (with the 2013 release) to the yearly deployment model, that no new maintenance releases usually come after February. By March they need to be at work on the next version if they are to make the normal release window the following November.

I don’t dispute that there seems to be recurring valid complaints with SketchUp Customer Service.

It is not you I’m attempting to convince.
It is the general readership who also may not be technically computer savvy.

The OP attempts to use the following “logic” as proof …

This sounds on the face of it to be definitive, but it is a flawed conclusion.
The problem (a driver with a bug) existed on the computer before SketchUp was installed.

It was the running of SketchUp that brought the bug to light for the OP.
But SketchUp did not cause the bug in the OEM device driver !

Which should have caused the OP to look up the “Freezing upon launch” help article,
which refers to the “How can I update my computer’s graphics driver?” article (see top of this post),
… which has the correct driver rollback alternative solution (that it’s had for years.)

Now, this is the Help Center article that SketchUp Technical Support should have pointed the OP towards.


REF:

SketchUp Help Center


#14

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.