Disable Plugin Windows on screen

Hi Guys,

is there a solution to disable the appearing of all the windows (of the installed plugins) when starting SketchUp? I still want to use the plugins, but I’m tired of having the screen plastered with all the windows…

OS: MAC, Mojave

Thank you!

It’s not clear whether you are referring to Tool Palettes or inspector Windows. In either case, if you click the red button to close one, it should not re-appear the next time you launch SketchUp. If there are so many that is tedious or if stacking makes it hard to keep one you want while finding one you don’t, you can click View->Tool Palettes to see a list and click to turn them off there. You can do similar for inspector windows via the Window menu.

thanks for answering, unfortunately thats exactly happening all the time, I close all the Tool Palettes, I close SU, I restart, and they are here again…
are you using also a MAC?

Yes, Mac. I’ve never had them come back when closed. I wonder if there is an issue with the .json file that remembers them.

Edit: I should have been clearer. The relevant file on a Mac is

~/Library/Application Support/SketchUp 2020/SketchUp/PrivatePreferences.json

First quit SketchUp. Then rename that file and restart SketchUp. SketchUp will rebuild the file as it starts. Your personal settings will have been forgotten, reset to defaults. But if there was a problem with the json file, that should have repaired it, letting SketchUp remember settings in the future.

1 Like

Is this happening with all plugins or just a specific one?

He said all of them.

Thank you, It works except for those:

  • “Soap & Skin…”
  • “Clothworks”
  • “PlaceShapes”
  • “1001BitTools”
  • “3D Tree Maker”

I deactivated them, thats the way I solved it :slight_smile:
Thanks guys…