Unable to customize tool palette display (Mac)

No matter how many times I save the work screen template
Some tool palettes just won’t disappear from the screen no matter how many times I save the work screen template…
It is very time-consuming to delete unwanted tool palettes from the screen every time.

Am I the only one suffering from this phenomenon?
Is it a bug specific to Mac?

Does anyone have a solution?

Are you talking about extension tool pallets? Many of them are coded in a rude way that defaults to on for every startup. The better made extensions should remember their tool pallet state through a restart.

The native tool pallets should not have this problem.

I meant the extended palette.
I can’t help if each code…
I would so much like to have an extension that can control that.

I’ll put all the palettes that can’t be erased together on the screen and
I will try to erase them each time.

On the Mac, you can’t dock the tool panel, etc.
I always envy Windows sometimes.
I can’t change the OS, so I’ll just keep working on it for now.

Thank you very much.

1 Like

I love soap skin and bubble… but I disable it all the time because it bugs me how the toolbar always shows up.


It’s up to each extension coder (the person writing the extension) to arrange for the tool pallet of their extension to remember it’s visibility state on restart, some of them are sloppy.

I do the same as you, group the zombie tool pallets ( they keep returning from the dead) at center screen and I close them every time I restart SketchUp.

I see 1001 bit tools, soap skin, clothworks, Twinmotion, and more that all appear on every fresh opening for me too. It’s mildly annoying.

On Mac we can create a custom header with extension buttons, but only one row deep.

If you install the Sketchucation tool you can use it to dynamically enable and disable plugins.
So you should be able to have them all turned off when you open sketchup and turn any of them on when you want them, just for that session, and they should then be off when you start another session.

But be aware I do not own a Mac, so this may not work for you.