Disable Autosave Sketchup Free

modeling

#1

Sketchup (web) is auto-saving after EVERY command. Which makes the program very sluggish, and I get command prompts about saving over a previous version if I do multiple clicks before it finishes. I don’t mind the auto-save feature, however it is REALLY excessive. How do I turn it off? OR how do I set it for a longer interval?

Thanks in advance.


#2

I’m not sure autosave is the culprit here… can you share a screen recording of what you’re seeing?


#3

Same thing for me, tried on a PC(Chrome) and on a MAC(Safari). Model size 39Mb. At every action on my drawing, the model is saved to my Trimble folder and the interface freezes. If I try to continue to work, most often this pops-up :

PLEASE CONFIRM.tiff.pdf (19.2 KB)


#4

Yes. That is it exactly! Thanks for posting. I will get a screen capture as soon as I can. Good to know it isnt just me. Thanks!


#5

Same problem It seems clear autosave is the culprit, as this only happens when “saving…” appears atoumatically in the upper left. Has anybody found a solution? This is making the app nearly unusable.


#6

Same problem here. I can’t work, Does anyone knows how to disable the auto save? I have to finish this project but in every minor change it freezes because of the auto save.


#7

I’m so glad you created this; I feel like I’ve been going crazy, and searches for something similar were coming up empty. It seems like everything will be going fine as I’m building a model, and then at some point, seemingly randomly, I’ll get caught in the autosave hell, where it just keeps saving after every single action. And it takes a long time to finish saving. It interrupts my whole workflow. I can’t work. I can’t undo. It drives me insane. I have found that I can resolve it at least temporarily by closing the sketchup browser window (I’m using Chrome on Windows 10) and then loading it all over again and opening my model and continuing my work…until it happens again a little later.

I haven’t identified a common pattern to explain when and why it does this. But it interrupts every single session now, and I sure wish someone would solve it, because it’s driving me crazy.


#8

This issue has been acknowledged as a bug and they are working to fix it.


#9

Acknowledged and fixed! That’s amazing support. High fives all around.