SketchUp for Web (Online) Disable Autosave?

Every time I draw a line, move an object or make any sort of model changing action the autosave feature on the online version of sketchup basically freezes all actions.
I draw a line > autosave processes for ages > I can’t do anything until it is done > repeat.

Please tell me there is a way to turn off autosave on the browser version of sketchup.

Since the online version is more prone to data loss (accidentially reload or crash tab) and the user has less direct file access, I believe autosave has been made an integral part of the software. Also users of online collaboration softwares are used to that changes are instantly saved.

But I would not expect it saves after every operation (there should be a time period like in the desktop version, maybe shorter).
What is the file size of your project?

The file is currently 22938 KB. Going to reduce it, I have some large builds “hidden” that I could save as separate files. Hopefully size reduction helps. Thanks for this information.

This is quite an assumption to make. Sketchup Free is not an “online collaboration tool” nor is it “prone to crashes”. It is however saving over a version of my model that I was happy with, with a version that contains temporary adjustments that I never wanted to save. If my browser does crash, I will have to reload this “work in progress” and hope I can somehow undo everything back to the model that I did actually save myself.

Autosave should absolutely be an option for the end user to decide.

Please make your own topic if you have your own issue. We can understand you experienced something disappointing, but anger shouldn’t make one negate a different discussion.

It is in the sense it is advertized (file sharing through Trimble Connect, one oculd indeed argue about that), but not in the sense of simultaneous editing.

I didn’t even say that. But it depends on the browser as a runtime, and through the years browser tabs used to crash at phases (when Chrome/FF introduced fast release cycles; when Mozilla introduced multiprocess and tab isolation; nowadays when out of memory which is common in SketchUp for Web). We are seeing that in the forum.


So this is your issue. Have you tried “undo”? I would expect after an autosave, the undo stack is not reset to zero, but lets you go back before the save. If not, this clearly needs to be reported as bug.

If the browser crashes, this could indeed be a problem: The autosave function does not save the undo stack to for undoing temporary operations. Maybe autosave should not overwrite the manually saved version. There is supposed to be a revisions list in Trimble Connect that is for this purpose (though I cannot find it).

My “disappoiting issue” is precisely for the topic being discussed in this thread. I can say that with no trace of anger in my voice, although your overbearing tone has me slightly pressed to keep my typing down to the usual volume and rate.

Once again, in case you missed it. The Autosave feature in Sketchup Free is overwriting save-points that I decided by myself. It forces me to save-as in stead to keep my old save-points which is neither helpful nor desirable. I prefer to save at my own leisure and when I am happy with my changes. Not to generalize, but I think a lot of software works this way and that most people are happy with that. There is no reason for Sketchup Free to reeducate its users in this area.

I went online trying to find an option or a way to disable the Autosave feature, and one of the first things I see is a posting with a surprising claim that the feature is somehow desirable because Sketchup Free is an online collaboration tool that runs in a browser and by the way is prone to crashing. Like, wtf?

I don’t normally rekindle old threads this way but I wanted to voice my disagreement because I believe a lot of users feel the same way. The autosave is overwriting a model that I saved as a “stable” version, with a version that I am currently editing. If I’m several dozens of steps into a modification that I regret, sure - I can press Undo several dozens of times. It’s just not very user friendly that way, is it.

I understand that some people may prefer Autosave. By all means keep that feature available. But some of us don’t. We should be allowed to disable it, it’s not an unreasonable request I think.

Thanks for this perspective and feedback, Michael. I am on the look out for ways to improve how people manage files in SketchUp for Web, so this suggestion is definitely under consideration.

We do think users should have more control here, and you’re right that we’ve edged on the side of caution (since some users do not have consistent saving behavior. For your information, SketchUp for Web also caches your model in the background, in case you experience a browser crash while editing. (I can see why this might not be good news for you).

Anyway, the point is, we have spotted a few ways to improve here and I’ll make a note to follow-up on this thread when we have some progress to share.

1 Like

Hi, any updates on this issue?

I haven’t been using sketchup much recently, but I’ve found that it seems to be more of an issue with larger file sizes.

Hi. The online free version’s constant auto saving is a significant issue for me as well. It’s extremely laggy while saving and it seems to be constantly saving. This is an easy fix guys! Please help!

This is a huge issue for me as well. I have deadlines I need to meet, and I don’t have the money yet to buy a new decent computer. I’ve been able to get by with my current computer, but since my deadlines are becoming more frequent, I can’t afford for my process to be so slow anymore. At this rate, I’m forced to have only one tab open (sketchup), and I can’t have anything open in the background (iTunes, Word, computer files, etc.). My entire computer has actually crashed BECAUSE of the autosave feature multiple times, deleting a lot of my work.

I know this feature was meant to save work in the event of a sudden browser/system crash, but it’s doing the exact opposite of that and wasting time that I don’t have.

I doubt I’m the only one in this situation, so it would be really helpful to a lot of users who depend on this program if we were given the option to either extend the autosave time or turn it off completely.

I’m experiencing this issue too. The last time I used Sketchup for Web was several months ago. At that time this was not an issue.

Now with every save the app goes CPU bound for about a minute when using Chrome. It takes significantly longer when testing with FF.

With the current save performance, I definitely need control over autosave in order for Sketchup For Web to be usable again.

Try a different Browser, it could be a browser setting that is causing the issue.

starting using sketchup web yesterday, and my current project is already made unusable by autosave kicking in and making the UI mostly unresponsive. ATM it’ been “saving” for something like 16 minutes after I opened the project, draw a couple lines and tried to remove one :cry:

This and, as mberg mentionned, there are pretty good reasons for NOT wanting autosave anyway as it imposes a workflow that doesn’t fit everyone.