Deactivate Autosave for Sketchup Web?

Sketchup Web seems to grind to a standstill once a file reaches any level of complexity, forcing save after save after save, when you make the least change. I and others have written about this problem but it does not appear to have been solved so far. Any help much appreciated.

1 Like

I am using Sketchup web for my personal project as it is convenient for me. Problem started when my file grow big and autosave function is effecting my performance. I reported the problem to deactivate auto save but received a negative reply that currently there is no solution available. Why would the developer not think of that? Save after save for sure will kill performance time.
Anyway if it may help you, Try to down load your file to ensure backup, everytime you see a need to save (do not use save funtion). When working back with you file always open your last download file and always do not SAVE in SkecthUP or Trimble.
In this way everytime SkecthUP try to auto save, it will have no file to save. In this way I just skip auto save and back to work. I find this better than wait for autosave to finish.

Thanks, samson for pointing this out. Great bit of detective work on your part ! I think you’re right that this problem has plagued the online Sketchup system for years which in my mind suggests the issue may in fact be insoluble, one, and / or two, that the online version functions primarily as a marketing tool, the real goal being to sell the standalone version of mac and windows. I hate to sound cynical cause I’m a total fan of cloud based programs. I’ve subscribed to the Onshape CAD for mechanical engineering, a cloud based next generation CAD system created by the original founders of SolidWorks if I understand correctly. It works amazingly well and is great for creating complex mechanical components. BTW its an easy matter to export these and import them into Sketchup.

One of my favorite features of the Web GL online Sketchup is the superior clarity of its GUI which seems to completely eliminate line stair stepping. The problem is when you use the export feature it apparently uses the old graphics engine which produces noticeably jagged lines.

My latest workflow strategy is this:

  1. Use the stand alone Windows Sketchup to draw in.
  2. Upload that into the online Sketchup.
  3. I don’t even bother to save it as that usually crashes the system for files of any size
  4. Go through the scenes one by one, using a screen capture program - the Chrome extension
    Makescreenshot.com
  5. Load these into google photos where they are easily shared and viewable as a slideshow

I’d say that’s living on the edge. If your computer crashes and you lose your work, how much time will you spend re-modeling to get back to where you were?

That seems like a lot more work than you need to do. If you’re modeling in the desktop version, why are you uploading the file to SketchUp for Web to make your screen shots? Why not just make your screen shots with the model open in the desktop version? Or why make screenshots at all? Why not export images from the model? And you could export an image sequence of all the scenes in one operation if you do that through Export>Animation.

My impression is that the online Sketchup GUI - because it uses the more modern WebGL graphics system - produces a much higher quality image totally free of stair stepping in an objects edges. On the other hand with the standalone version of Sketchup screen captured images or exported images have noticeably stair stepped edge lines as do images exported from the cloud based Sketchup.

My hope is eventually - if it is in fact the case that WebGL produces a superior image, this means of rendering will be used in the image export routine as well.

I don’t see that in my exports but maybe your graphics card’s capabilities are different.

That’s so true… Hope SketchUp can find a permanent solution. What I just do is manually save online at the end of the day with a new file name. added more work to me.

1 Like

I have the same problem that autosave freezes my workflow.

@Sketchup team: If you can’t disable autosave why not at least extend the time to like 30mins or even an hour and maybe bring up some info message before?

No need of saving every couple of minutes. Will also help your server resources.

1 Like

Same here, autosave with a slow connection is a nightmare! This problem is not new at all, why don’t you put a toggle on that, it’s a very basic option and SketchUp online is cruelly lacking all of them.
Plus since in 2020 you still don’t support any kind of Linux, Online is the only possibility.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.