Sketchup Free Continuously Saving causing Lagging and Popup Message


#1

Hello Sketchup nOOb here. Coming from a 12 year background in fabrication I decided to finally learn the software side of things. Soo until I sell a project and purchase a version of this software I’m using the web based system. I’ve google searched endlessly but cannot figure out how to turn the auto save function off. I’m starting to think the developers are messing with me so I upgrade… The past week I’ve been getting a popup window about overwriting the current model due to the program auto saving after every single function I apply to the model. Please help.


#2

Are you using the web (free) version or the standalone (Pro) app? It’s not clear from your profile.

Are you saving your models locally (i.e. on your computer’s HD) or the cloud (e.g. Dropbox, etc)?


#3

Sketchup web version. Saving via cloud and I have deleted some models from another project thinking I used up 10gb which I believe is the limit of free space. This issue comes and goes but will go on for a couple hours then stop for a couple hours. It’s making things very difficult… I just want to know how I can turn off the auto save function (if possible).


#4

Can you please post a screenshot of the pop-up you are seeing?


#5

Continuing the discussion from Sketchup Free Continuously Saving causing Lagging and Popup Message:

I am having the same issues, my opened model is 39Mb and overtime I do something to my drawing (like opening a group), the model saves, and the interface freezes and I am unable to proceed with anything until the model is saved. Sometimes, if I try to continue, it looks like the model is saved again before the first save is completed and then the pop-up appears :

PLEASE CONFIRM

There is a newer version of this model in your account.
Do you want to overwrite it with your current changes?

Using Sketchup Free on MAC and PC, both with the same issue.

PLEASE CONFIRM.tiff.pdf (19.2 KB)


#6

Thank you for the report and thanks for the screenshot @BroumBroum. I am not sure what’s causing this at the moment but we will investigate and try to fix it ASAP.


#7

We identified this bug and it occurs in rare circumstances. We will be patching it very soon. One workaround is to switch to another model (or a new model) temporarily and open the model again, which should avoid the bug. Sorry for the inconvenience and thanks for reporting it!


Disable Autosave Sketchup Free
#8

This bug has been fixed. Please note that you’ll need to reload the app to get the fix.

Thank you all for reporting!


#9

Bug report- one day patching-bug fixed!!
Can we have the PRO version web-based as well?:smiley:


#10

Noooo! Please, not that (in complete seriousness). Fixing bugs quickly is great, but that can be accomplished without resorting to a web-based implementation.


#11

I’m still experiencing the freezing up after continuous auto saving. No pop ups but the lagging is pretty annoying. How can Autosave be turned off??


#12

Are you still experiencing autosaving after every action? That should not be happening. Did you reload the page after my fix announcement?

There is currently no way to turn off autosaving, sorry. But it should only occur every 5 minutes.


#13

Apologies for the thread hijack, however given the history I think it’s better to add here than start new.

I’m experiencing the same issue as originally reported. Specifically the model mismatch error message occurring every five minutes on auto-save.

I’ve reloaded the browser (tried two different browsers in fact) today and am still seeing the issue. Perhaps the fix wasn’t completely successful.


#14

I too am having this issue. I looked at the browser dev tools to get some insight into what might be going on. Every time I attempt to save my model, the POST request I send (files?parentId=####) the server returns a 500 status.

After the first time this happens in a session, a POST request is made to sentry.io with a bunch of info (a little too much info if you ask me) detailing all of the actions I’ve done up until the point that my save caused an internal server error, and I get back a 200 status.

The next thing that happens is a call is made to “versions” to get all of the versions of my model (–and this is just a wild guess) is used to ensure that I’m not potentially overwriting a newer version of the model with old data. The response contains a list of all of the versions that exist on the server. Surprisingly this list includes the version of the model that failed to save. My guess is that we keep getting the popup because the version object referenced on the client side will not update unless it gets a non-error response from the server when sending the POST request to save the file.

So what it boils down to is that my model was saved, but somewhere down the line, an error occurs after successfully writing and committing the model data but has an error (server side) while creating/before sending the response.


#15

Having this issue as well; every 1-2 minutes everything freezes for 5-30 seconds as it autosaves. Was very disappointed to see that the free version was no longer downloadable, along with the removal of so many features, and the web app has been nothing but problems for me.


#16

Free version (SketchUp Make 2017) is still available for download.


#17

Hi again. Still having the lagging/freezing issues during autosaves. They seem to be closer together then 5 min but I could be wrong since I haven’t timed them. The lag lasts like 5+ seconds. I plan on purchasing a different version of the software and just want to make sure these issues aren’t occurring in the paid versions?