Dimensions Tool - Two Issues

Hello

I am fairly new to Sketchup Pro. I am having a couple of frustrating issues with the Dimensions tool… or at least, it is behaving in a way that I don’t understand.

Here is my SKP file.

Here is a video that demonstrates the two issues I am having.

Issue #1 - I am trying to measure the width of a pathway. I can anchor the starting point of the dimension but cannot anchor the other end. I have tried turning on hidden geometry, I have tried to draw a guide point, I have even tried to draw lines to make the dimension anchor. Why can’t I apply the dimension where I want it? (There are numerous other locations on my model like this).

Issue #2 - when I do successfully anchor a dimension between two points, and go to position the actual dimension, very easily the dimension snaps out of line and changes to a different dimension and then I have to escape and start again to get back to my original one. (Video shows this). Why does this happen and how can I revert to the original centered placement of the dimension without having to start again?

Any advice welcome.

Not really part of your question, but I observe that these bare trees (of which there are 66 instances) contribute almost 7.4 million edges and 2.5 million faces to your model! The 16 instances of these bushy trees add another half million edges and quarter million faces. It will be a lot easier to work with your model if you either simplify, replace with proxies, or eliminate these geometry-heavy entourage elements!

That said, both of the issues you show in your video look like normal (though potentially annoying) SketchUp behavior to me.

A dimension needs points at both ends to anchor. It will anchor to an endpoint or midpoint of an edge, but not to an arbitrary point. Sometimes it will seem to have snapped but actually not have found a usable anchor. Not seeing exactly what you did I can’t explain why it wouldn’t anchor to a guide point. It should…

When you pull a dimension out from its anchors and they are not aligned directly with one of the model axes, SketchUp tries to guess which of the possible directions you are trying to dimension (x, y, z, diagonal,…?). It bases this on the direction you move the cursor, sometimes switching between possibilities when your intent is ambiguous in 3D. It helps to orbit the model, as that influences how SketchUp tries to figure out what you want.

Also, I notice that the streets in your model are neither flat nor level to the x,y plane. You can see this if you try to draw a line starting at one edge and lock the direction to the red or green axis. New edge will disappear and reappear from the street as it intersects the non-level surface. Dimensions do the same thing.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.