Dimension inside

I have a model that has a depressed area in the middle, so to speak. I want it to be a specific distance from the edge of the object. However, when I use the dimension tool, it will not lock on to the edge(s) only the end points and that is not what I need/want. Any suggestions on how to note this other than a text? I want it to be able to be changeable just like the other dimensions do.

Thanks in advance.


Can you share the SKP file so we can see what you are trying to do?

True. The dimension tool locks only to endpoints, intersections, or guides. It won’t grab an arbitrary point in the middle of an edge. As DaveR implies, there may be ways to fake it depending on quite what your model is doing. If you share it, we can see.

Here is my model. It is an “update” to another and the 2 pieces in the middle need to be 2.5" from each top and bottom edge. Want that on the dimension layer so someone won’t forget (me!).


Sketchup_Large_Piece_2D_layout.skp (124.1 KB)

Is the selected dimension the one you want?

You could put it on the part by creating a temporary guideline across but it wouldn’t be the proper location for the dimension. If you must do that, erase the guideline after the dimension is in place.
Screenshot - 1_6_2020 , 4_35_23 PM

If you want the dimension to be connected to points on the model, you should add the dimensions at the end points like in my first screen shot.

Edit to add: if you are wanting to dimension in the middle of the part and you want the dimension to remain connected to the model, use LO’s dimensioning tool instead. It will update when you update the reference.

Thanks. However I am somewhat confused. How did you get the dimension to do what it did in the first screen shot? I have tried all that I know and it still wants to go from the inset corner to the outside corner not anywhere else — unless I am missing something.


Do you mean in the one where the dimension is place outside the part to the right? I just clicked on the corner of the inset border and then the outer corner. Nothing special.

Here I’ve replaced the dimensions in LO and reduced the clutter. I did put that dimension in where it really doesn’t belong just to show that it can be there.

Thanks once again. however I don’t see how you got the dimensions with the arrows for them to be where they are. Tried the text but that does not do that. So… once again need to better understand how dimensions work… or could work.


Which dimensions are you referring to? The 2.50" dimension that changes to 3.21" in my first GIF was added in LayOut as were all the dimensions in the last screen shot showing the entire part.

The screen shot that shows the clutter cleaned up. 0.38", 1.25", etc.

As I wrote:

I deleted your dimensions in the SketchUp model and put in dimensions in LO.

LayOut’s dimension tool will put the dimension text outside the dimension line and add a leader if the dimension doesn’t fit. In the extra vertical 2.50" dimension, I edited the dimension and moved the text off the part. The leader was then added automatically.