Dimensioning wrong in layout

Module 4 Floorplan.layout (2.4 MB)

Hello, I can’t work out why my dimensioning isn’t working in layout. The sketch up model I have imported is 9600mm across the top and 9100mm down the side. When I go to dimension this in layout the 9600mm works fine but the side dimension is completely wrong. Does anyone have any ideas what I’m doing wrong. The scale is supposed to be 1:50 but it looks far too small on an A3 page to be right…TIA!

First, you haven’t actually got a plan view of the model. The Camera is angled slightly in SketchUp. You can tell that because the word “TOP” is not displayed in the upper left corner of the SketchUp model window and the fact that the vertical blue axis is visible.

In LO you can tell that because the SketchUp Model panel shows (None) for the Standard View.

If you select the 4527 dimension you’ll see that it shows the dimension has no scale. This is due to the incorrect set up in SketchUp.

The fix: First select the Standard Top view, Zoom so the model fits the window. You need to be creating scenes in SketchUp to use in LayOut. Using Last saved SketchUp view is bad practice. Save the changes.

Update the model reference in LayOut. Delete one of the viewports. You have two stacked on top of each other. Choose the Plan scene and set the scale to 1:50. With the setup done correctly in in SketchUp you’ll be able to set a scale correctly.

Replace the the dimensions. Make sure Auto Scale is turned on for the dimensions. It normally is and should be in your model but I’ve seen users turn it off without understanding what they are doing.

2 Likes

Thank you so much for such a complete reply. Thats so helpful

1 Like

I’ve imported the model with the right camera setting but I’m still getting the wrong dimension. I think the sketchup model is tilted maybe? Is there anyway I could get the sketchup model back flat?

Upload your SketchUp file so I can see what you’ve got.

Module 4 layout.skp (2.4 MB)

You have the Camera set to Perspective. Notice that you can, again, see the blue axis in the scene.

Change the camera to Parallel Projection and then right click on the scene tab and choose Update.

Module 4 .layout (2.4 MB)

Sorry, last thing…I’ve got the dimensions sorted but I have these guidelines on the right hand side of the model, I can’t seem to erase them. Any ideas? Thanks so much

If you don’t need them anymore the best thing to do would be to get rid of them in the SketchUp model. In SketchUp use Edit>Delete Guides.

If you still need them for something in the SketchUp model, you can render the viewport as Vector and they won’t show.

I see you still have the Last saved SketchUp view selected for the viewport although you do have a Scene 1 created in the model.

Thanks. I just use the ‘send to layout’ can i import the scene from layout?

If the scene is active when you send to LayOut, that scene will be used for the first viewport. You’ll only send the SketchUp file to LO once. After that, you will copy an existing viewport for additional views in the document.

Click Scene 1 in SketchUp and Save. Send to LayOut. With the viewport selected, you should see Scene 1 displayed in the Scene field in the SketchUp Model panel.

1 Like