Dimension value missing

When adding dimensions to some objects, the dimension lines show up, but the value is missing. it shows up when i change the position from where im veiwing it. But the new position might not be the scene view i want to show.
i have tried realigning the axis to the object (if it was on a weird angle or something) but that does not help
Any ideas?

Sorry to hear that you are experiencing problems. Check out a previous response from a different thread above. If that does not work let me know.

My other suggestion would be to close and re-open SketchUp and your file. Is your wall flat? Sometimes the dimension can be “eaten” by the wall (see below screen shot example) if moved after dimensioning or even if dimensioned incorrectly. Perhaps also you could attach your SketchUp file so we can take a look?

Cheers!
AlexB

1 Like

How did you create those dimensions, I wasn’t able to reproduce the disappearing. Does a change to “Align to dimension” instead of “Align to screen” affect this behaviour?

1 Like

I’ve seen this happen when playing around with the field of view setting (whilst ZoomTool is active.)

Seems like Zfighting with respect to the camera plane.

Cotty! Thank you! that was the problem, ive never run into it before! Thank you so much :smile: :smile:

thanks for the suggestion Dan

Thank you everybody for your replies and suggestions - it was the dimension aligned to the screen that was the problem :slight_smile: :slight_smile: :slight_smile:

I’m having the same issue in Sketchup 2019 with the dimension value disappearing when Alighn to Screen is chosen. Is there a way to get it to be visible with Align to Screen too?

(I’m pretty sure it used to work once upon a time… )

If you(r eye hight) is in the very same plane as the dimension, you won’t see the text alinged to the screen, although there’s no reason to not show that text.
Orbit slightly out of the dimension’s plane and it should pop up again. Is that the case?

Example: you have some geometry on Z=300. Dimension some edge in the horizontal plane Z=300.
Align the dimension text to the screen. It should be visible in 99.9999% of the camera positions.
Now change the eye hight to Z=300 and the text will disappear. It is argueable if it should disappear.

2 Likes

yoni,

the standard view cameras have ±2° of ‘tolerance’, if setting a views direction with ruby, you may need to accommodate the deviation from the equivalent :send_action

is this really a GUI or a ruby question?

john

Seems to be happening in quite a few angles and it goes in and out of view several times as I zoom in and out.

It’s acting similar to when you have a model that is too large (axes point is far) and geometry gets cut out when you zoom in, but it’s only happening with the dims. Geometry is visible throughout.

Field of view is set to 65.

Maybe it has to do with the font size or something…

See video:

Definitely not along the line of my answer. It looks buggy.
There are advanced settings for dimensions to show / not show depending on distance etc. But even that doesn’t seem to apply.

by the look of that, I think ‘fast feedback’ is turning them off during orbit, but resume isn’t doing a redraw…

john

I’m having the same problem. I tried saving and restarting,experts settings in dimensions and nothing Did anyone ever figure out how to correct it? I’m using Pro 2021

Can you share the SketchUp file so we can see what you’ve got?

Thanks so much for helping. I saw someone saying being to far from the origin might be an issue. I tried zoom extents and saw a large field but it does not correlate to any objects out that far. Tried erasing the the space but no different. Not sure if I’m describing it well. I tried zoom extents on a new model . I went out very far and when I hit it it properly showed me the one object I had drawn near the origin. thanks again
TIM MEEHAN sent you 1 item

[

## TIM MEEHAN sent you 1 item

Lapides spa eng 1.28.22.skp

](Transfer - Dropbox)

Best
Tim

There were 7 tiny entities at a huge distance from the rest of the model. I deleted them. i also fixed incorrect tag usage and purged unused stuff from your file.
Screenshot - 1_28_2022 , 8_46_30 AM

Screenshot - 1_28_2022 , 8_47_18 AM

File size reduced by about 99.25%.

See if this one works better for you.
Lapides spa eng 1.28.22 purged.skp (475.0 KB)

If you look at the drawing of the spa closest to the origin and try dimension the wall that has two jets adjoining the steps you can see the problem. If you zoom out you can sometimes get them. I need to be able to be in close as they are for shop drawings which need approval.
Thanks

Best
Tim

You could do the dimensioning in LayOut.

I’ve added the dimensions shown in blue. Are they the sort of thing you are trying to do?
Screenshot - 1_28_2022 , 9_06_21 AM

Amazing. How did you find the tiny entities?
What is tag usage? What is unused stuff?
I can’t thank you enough for the quick reply and fix!

Best
Tim