Dimension values hidden in certain angles when orbiting in SketchUp Pro

Having a model with dimensions the dimension values disappear and show up again when orbiting. It appears as there are some invisible objects in model space that covers dimension values only. Zoom level also influences when dimension values are shown.
I suspect that it could be a bug in SketchUp or a graphics driver issue. The latter is updated to the latest version. Computer is Lenovo ThinkBook with Windows 10. Graphis is NVIDIA GeForce GTX 1650 with driver version 30.0.15.1259.
Anyone who experienced something similar?


Alssundvej 44 - trappe1b.skp (3.6 MB)

I’m not seeing that in your model (and haven’t seen it in any of my models). My first suspicion is graphics drivers, not SketchUp. Did you check with Nvidia to see that you have the latest drivers for the GPU? When you look at SketchUp’s Preferences>OpenGL does it show the Nvidia card as the selected on? Is Fast Feedback turned on or off and does changing the state of the tick box change anything?
dims

FWIW I see incorrect tag usage that you should fix. Untagged should always be active. Don’t make a tag active. Note the pencil icon.
Screenshot - 9_29_2022 , 8_12_10 AM

There’s a bunch of edges and faces that have tags. ALL edges and faces should be created and left untagged.
Screenshot - 9_29_2022 , 8_12_39 AM

Hi Dave, thank you for your effort.
The OpenGL preferences refer to the right graphics card and the driver is up to the latest version.
None of the OpenGL settings have any influence on the hide-issue.
Below video shows how zoom level is hiding the label as well - does that also work for you?

Your comment about my tag usage - how would you recommend using tags to turn on/off elements if not selecting which “layer” to draw on? I know that I can change tag later in Entity Info but then I have to select edges af faces again. Or is there a better method?

Yes. That seems to work fine on my end, too.

Yes. There is a better method. Leave Untagged active at all times. Create and leave ALL edges and faces untagged. Create groups or components to contain the geometry. (You’ve done that in the model, at least to some extent.) Give tags to the groups or components and leave the geometry inside them untagged. Working this way means you never have to chase the active tags. When you edit a group or component you are still working with untagged geometry. There’s no chance of making errors by forgetting to change the active tag. Turning off the visibility of a tag will hide the components/groups that have the tag and the geometry inside the components/groups will also be hidden.

Here in this model I’ve followed those rules and you can see how the various components can be shown or hidden.
tags

The following is from the Help files: Controlling Visibility with Tags | SketchUp Help

Especially this:

By default, any new raw geometry you create has the ‘Untagged’ tag. Before assigning tags, make sure you understand the process of making groups and components. Your models will be much more predictable if you refrain from assigning tags to entities like edges or faces, or changing the active tag.

I will report the hide issue as a bug.
OK, I understand your tag-recommendation. I will try following it going forward :slightly_smiling_face:
Thanks again

To whom?

I believe that Trimble is the only entry even if the problem is caused by the driver.
They know how the graphics card is utilized by SketchUp and that information is needed in order to debug the driver.