Dimension Tool Won't Snap to Viewport with Skalp Section

skalp

#1

I’m not sure whether this should be a Skalp issue or a LayOut issue, so I’m starting here. All of the tools will snap to the drawing except the dimension tool. Here is an animated gif to illustrate.

I’m running the updated SU Pro 2016 and macOS Sierra and the most current Skalp 2 beta


#2

Looks like it’s not just a Skalp Section cut issue, here I have an older drawing from before I had Skalp, and I still can’t get snapping to work on some areas of the section cut.


#3

The lines you see in a section cut are not snap-to-able. Use TIG’s Section Cut Face with edges not hidden. You’ll be able to snap the those edges. There may be a similar option with Skalp although I haven’t used it so I can’t say for sure.


#4

I’ve always been able to snap to them before…it just started happening. That was why I went to an old drawing, to check if I could still dimension it as I had done before. Could it be an issue with the latest update of LayOut for Mac?

Edit: @DaveR maybe you’re right, on closer inspection, I replicate the same behavior with the old drawing in LO 2015. So maybe Skalp was adding lines for me to snap to and I’m just used to it, and it’s not now.

Can someone move this to the extensions section for me?


#5

It could be there’s a setting in Skalp that makes edges that you can snap to. We need a Skalp expert. :wink:

I was going to add the section cut lines have never been edges like the ones you draw and so things like dimensions and inferencing don’t snap to them. They don’t even get treated like the other edges for application of sketchy line styles.


#6

I wonder if in the past it was snapping to the intersection the that is in the background since these are typically orthogonal viewports. It just seems like it’s a new issue that I haven’t had in the past, considering I’ve been using LO for a few years now.


#7

That could very well be. One thing I’ve found useful on occasion is to place a guideline or two to create a snap-able point. The guidelines don’t show if you render in vector mode.


#8

Couldn’t help but notice in the latest beta release notes that there was a fix for this in Skalp