Dimension tool not allowing me to get a straight dimension line between two points

dimensions
dimension
measurements
dimensiontool
dimensioning

#1

Folks,
Hope everybody is having a great time using Sketchup.
Recently, I upgraded to Sketchup’s latest version ( 17.2.2555 ) and now I am not able to get straight dimension lines between two points of an edge.
First, I start the selection at one end-point of the edge and finish it at the other end-point, or I click somewhere on the edge directly. Then, when I drag cursor to to get the dimension arrow to a desired distance from the edge, the dimension line stops being straight and it breaks, producing a dimension corresponding with an angled view, but not the true length of the edge.
See uploaded picture for an example.
The only time I can get a straight dimension line on an edge is if the edge is in alignment with an axis. However, if the edge has some inclination that takes it out of alignment with any of the axis, the dimension tool does not produce a straight dimension line.
Am I doing it wrong, or is there a setting that controls how the dimension tool works?
Thanks in advance for your help.
Raoul


#2

It’s not actually breaking your edge, what you are seeing is a “leader” from the dimension to the end vertex of the edge. Yes, it can be fussy to get the dimension tool to measure parallel to a slanted edge. It sometimes takes some fiddling around with the direction you drag away from the edge. It also helps if you orbit the view until you are looking more or less directly at the plane in which the edge lies. Then try to drag directly away perpendicular to the edge.


#3

Steve,
Thanks you so much for your help. Maybe I caused some confusion with the way I worded my question. I never meant that the dimension tool was breaking my edge.
I wrote: “the dimension line stops being straight and it breaks” I meant that the dimension line was breaking, not the edge.
I know sometimes getting the right reference is a fuzzy process, but I have fiddled and fiddled and then fiddled some more to no avail. :confounded: I have orbited the view in many different ways to get a good frontal view of the edge also with no result. Here is a test file. If you can get it to work, would you share a screenshot?
This worked for me before I upgraded. :rage:
Thanks

Software-Sketchup-Qusetions-02-DimensionToolBreakLine.skp (1.2 MB)


#4

impossible,
so a work around, make the line a group , change axis of group to follow the line, then place the dimension inside the group


#5

Dear Philip,
I know!!! :smiley: Right??? Thank you!!!
I was going crazy. :stuck_out_tongue_winking_eye: I thought, could I be the only dumb-ass that cannot figure out how to use the dimension tool properly on a simple edge???
Now, how is it possible that a sophisticated and seasoned software that has been around for over a decade, used by lots of smart fellows has trouble with something so simple?
Thanks you so much for your help.
Raoul


#6

You can add temporary faces to help the inference know what you want.


#7

Box-man,
A W E S O M E !!! :sunglasses:
The gif animation helped a lot.
Long live to the King Box from Down Under :+1:
Thanks a lot.
Raoul

Now, Sketchup crew, if you are listening, it would be a very nice feature if you could press some key (like shift, alt, ctrl, or any key) while simultaneously dragging out the dimension arrow, and have Sketchup plot a dimension arrow parallel to the edge you are trying to measure. :wink:


#8

Just wanted to give Philip (pcmoor) some more kudos :clap:
His solution works just as well as Box’s
I just had never changed the axis of a group and thought it would be involved, but just tried it and it is a piece of cake.:cake:
I think is great to have both alternatives.


#9

Or optionally holding down the mouse key after selecting the second point could let you select a custom vector to measure in, and after that you could click a third time as usual to place the dimension, similarly to how the protractor works.


#10

This topic was automatically closed after 91 days. New replies are no longer allowed.