Dimension tool, conflicting information


#1

Hello.
Would someone be able to help with the Dimension tool
I must be missing something as it keeps giving conflicting information.

Measuring some segments with the tool gives different dimensions/cotations. (eg: the bottom segment are 89.92 mm and sometimes 90.00 mm).

Ideally, the walls need to be 90 mm, and I was measuring at it seemed 90 mm was not respected everywhere in this drawing. (The walls are on a hidden layer called Walls). I am quite confused. Thank you if you can help, :wink: the skp file is attached as well as a photo.


PS: I have a second issue as I am trying to delete the x- layer says it is not empty. I am sure it is empty, but that is an other thing I must be missing. Anyway that is an other story (and probably needs another post/question all together)…

Cotation not 90 mm v3 (Sketchup 7).skp (99.2 KB)


#2

You attached the skb file…

@jody - is it intentional that skb files are allowed on the forum?


#3

It appear that you have some tiny edge segments around there. They are the source to the difference you see as the snapping will some times pick one of the ends of these fragments.


#4

Ooops my mistake, in the confusion I uploaded the skb. All fixed the skP is uploaded.


#5

Hello tt_su. Oh I see, that explains what the issue is. THANK YOU !

From the picture you posted I can see where they are located. How can you see and select such small segments, because when I zoom in (mouse scroll) the model disappears after a certain point/zoom ?


#6

I just had a hunch and dragged a selection box over the point where I saw the dimensions where attached.

But I just realized I could use my Solid Inspector extension to pin-point those small edges - and there are actually three of them:

http://extensions.sketchup.com/content/solid-inspector²


#7

Fantastic. Really fantastic. Your reply puts me out of my misery, I do thank you so much for your help, it is invaluable. :wink:

Thanks !


Found it, right click on model and do “Detect Short Edges”, and they are clearly shown. Thank you.


#8

Hi tt_su. I installed the Solid Inspector extension which is useful to find 3 small edges. How do you actually get the 3 little signs with the question marks like on your second picture, to pinpoint where the issues are ? Thank you.


#9

You have to have the group/component that contain the edges selected or open.

Then you might also have to enable the search for short edges via the context menu when the tool is active:


#10

Thank you again tt_su !


#11

Hi Luds,

Open the Layers Manager and delete all extra layers until everything is back on Default Layer 0.
As you delete each layer, you’ll see a pop up window. Select: Move contents to Default layer
No worries, you can put things back in order after you learn more about SketchUp layers.

This article explains how things work.
Does SketchUp Support Layers? — SketchUp Help


#12

Hello Geo, thank you for this it worked like a charm ! :smile:

Also the link for the article was great to follow. Thank you