Dimension scale bug in LayOut 2016


#1

Hi, I found a bug in LayOut 2016 with dimension scale (see picture).


Dimension don't show true length
To Upgrade or Not?
#2

Here is video with problem:
Dimension scale bug in LayOut 2016


#3

Real Size (Paper Space) is 50mm

You select 1/24 , so it indicate 24 x 50 = 1200mm
You select 1/100, so it indicate 100 x 50 = 5000mm

How about refreshing scale list (Layout -> Preferences -> Scale )?


#4

Please watch the video above. I didn’t select 1:24 - LayOut 2016 creates this scale itself when I choose 1:100. If I do the same things in LayOut 2015 there is no problem - it correctly shows me 5000 mm when I choose scale 1:100 for dimension line.
I didn’t use custom scales (Layout -> Preferences -> Scale ), only standard.


#5

Hey! I managed to reproduce the exact same problem in my LayOut. This is extremely frustrating as I have an exam tomorrow and my file keeps messing up the project dimensions. I hope someone can address this issue.


#6

Maintenance Release 1 update doesn’t fix the bug :confused:

Here is video with problem:
Dimension scale bug in LayOut 2016


#7

It works perfectly for me. Could you upload a LayOut file that displays your problem?

The only explanation I can invent is that your view scale is not what you think it is. Is the view using Parallel projection?

Anssi


#8

Hi all-

There is a bug in LayOut that manifests itself in documents that are set up with metric units. It also seems to depend on the size of the object being dimensioned, although I don’t have an explanation for that at the moment.

A very simple explanation of this issue is that the dimension inspector gets confused about which scales are available, and temporarily switches back to using the list of imperial scales instead of the list of metric scales.

There is a workaround for this issue - you will need to go into the LayOut Preferences dialog and add custom scales for each scale that you want to use. Custom scales are handled differently and shouldn’t be affected by the bug. It’s perfectly fine to have a custom scale that duplicates an existing LayOut default scale - so if you want to work with 1:10, go ahead and add a custom 1:10 scale even though there’s an existing 1:10 scale as well. Since these custom scales are saved in LayOut preferences, you should only need to do this setup once.

We’re definitely working on a fix for this, but unfortunately weren’t able to get it done in time for maintenance release 1.

Let me know if the workaround doesn’t help.

Thanks,
Marc


#9

Of course I am using Parallel projection. Hope files will help to understand and solve this problem.
dimension bug.skp (153.4 KB)dimension bug.layout (131.4 KB)


#10

Yes, I am using metric system only. I will try to use custom scales.


#11

Unfortunately custom scale doesn’t works.


#12

You’re right, the workaround seems to work on Mac but not on Windows. I’ll do some more investigation and will report back if I find a different workaround.

-m


#13

Ok, we will wait else.

Roman


#14

Why didn’t I have the bug? Is it because the document I used has been started originally in an older version of SketchUp/LayOut? My document is also using metric (mm) units, with no custom scales defined, and I don’t have a Mac.

Anssi


#15

I’m having the same or similar problem using Architectural format and fractional inche scales on 64-bit Windows 10 with SU Pro. This is on a model and Layout file created with SU Pro 2015. Using the 1/4" = 1’ scale, my dimensions show as double what they should be plus a few inches added for good measure. When I created a new Layout document using the same model, format, and scaling, dimensioning worked as it should.

At this juncture, it looks like I’m going to have to scrap my old LO document and start fresh. That’s a lot of work lost–not happy.


#16

Experimenting further, in the old LO doc created in SU 2015, if I change the scale to 1/8" = 1’, dimensioning works fine, when I change back, dimensioning is fubar again. If I change to 1/16" = 1’, or any other scale, its fubar. I created a custom 1/4" scale to no avail–still fubar. The view is in ortho mode, and parallel projection.Changing scales on the new LO doc created in SU 2016 works as it should. Dimensions remain the same. I’ve checked to make sure that all preferences and document setups are the same on both docs.


#17

So, I saved my problem document with various plan views as a scrapbook. I created a new LO document, then dragged a plan view from the scrapbook to it. It too had dimensioning problems. I then File:Insert(ed) a view directly from the SU file into the new LO doc. It dimensioned correctly. I had two views of the same plan on the same LO doc, one from the scrapbook and one from the file. The scrapbook view was fubar, the inserted view was fine.

I tried this in different combinations using new and old LO files with consistent results. It appears that, at least in this case, a LO document created in LO 2015, then opened and edited in LO 2016 will have dimensioning problems. Creating a new document in LO 2016 and inserting SU views from SU file, originally created in SU 2015, but updated in SU 2016, will dimension just fine.


#18

Okay, scrap my previous conclusions. It seems I only have dimensioning problems when Im using a particular document template. All other templates used to create a new LO file seem to dimension fine. I’ve gone through the template and deleted everything, then purged all external file links in document setup. Basically I’ve got a blank template–still new files created with it do not dimension properly. I have no idea why. Attached is a png of a 20’x40’ rectangle top view, parallel projection, dimensioned in both SU and LO. I’ve also attached the offending layout file.

Bad.layout (18.1 KB)


#20

I then File:Insert(ed) a view directly from the SU file into the new LO doc. It dimensioned correctly.

It doesn’t work for me. In this case I think we only can to wait for a solution of this problem from developers.


#21

I answered this one on SCF. You have Autoscale turned off. With it turned on, the dimension matches the one from SketchUp. If you increase the precision in your model and in the dimensions in LO, you’ll find that it displays a more accurate scaled dimension. I have noticed that you need to change the scale temporarily and then change it back to the desired scale to get it to update.