Dimension scale bug in LayOut 2016


#22

Thanks Dave. Appreciate the reply on both forums.


#23

I have exactly the same bug, is there any solution available yet? It’s pretty much impossible to make proper documents with this bug.

Erik


#24

The latest Maintenance Release was on February 29th but that didn’t fix the bug. So far the only workaround I can think of is to go back to SketchUp 2015 and work with that version.


#25

This bug is MASSIVE! I’m trying to do all of my technical drawing for a multi million dollar project and I’m second guessing if all my dimensions are correct or not… And then for Trimble to know about it and not fix it in the last maintenance release? What am I paying my yearly maintenance fees for again? :rage:


#26

I found temporary solution of this problem, but I can’t explain why it works. It just works. The solution is - copy into LayOut 2016 dimension line with scale you need that was made in LayOut 2015 and then copy its attributes to dimension line made in LayOut 2016. But after this don’t change manually scale of this line. For another scale you need another dimension line that was made in LayOut 2015 with this scale.
Hope it can help you.
Video with solution - https://drive.google.com/open?id=0B0VeR809fc4yUF9NNDRMZXR5akE


#27

Dear Sketchup,

It’s May 2017 in the meantime, and the bug still isn’t fixed. Metric dimensions still aren’t correct. Please fix this, since this is unacceptable for a 600 dollar piece of software.


#28


#29

Share the LayOut file so we can see the setup.


#30

I can’t, the file is too big. I’ll try creating a smaller file with the same issue


#31

You could upload it to Dropbox or Google Drive and share it that way. If you don’t want to make it public, send the link by private message.

Are you still using SU2014 as inidicated by your profile information?


#32

Good point, thanks :slight_smile: I pm’ed you


#33

I found several problems with your LO and SU files which I fixed. And then I get the proper dimensions. Here’s a screen grab. I’ll relate the problems after I get to work. I’m late getting out the door.


#34

OK, I’m very curious! Thanks alot


#35

Alright. Just in to work.

In LO, the top extension line of your dimension was not anchored to the model geometry. I placed a new dimension that was and got the results in the screen shot.

BUT before you deal with that you need to make some other changes.

First in SketchUp:

  1. Set the camera to Parallel Projection for the scene.
  2. Normally you would also set the appropriate Standard View but that part of your model is not aligned with any of the standard views. So you need to align the view to the faces in that group. Open the group for editing, right click on a face and choose Align View. Then close the group to exit edit mode and adjust the camera with Pan and Zoom only to show the part of the model you intend for that scene.
  3. Update the scene and save the changes. I didn’t look at the rest of your file but I would guess you have more scenes and viewport’s that need the same kind of attention.

In LayOut:

  1. Delete the bad dimension.
  2. Select the viewport. Look in the SketchUp Model inspector window and you’ll see the scene is shown as modified. That’s a bad thing. Deselect the original scene from the list. Don’t worry about how it changes the view for the moment.
  3. Update the reference so the changes in your SKP file will be showing . Right click on the viewport and choose Update Reference.
  4. In the SketchUp Model inspector window you can now select the scale at which you display the view. That wasn’t available before because you had the camera set to Perspective.
  5. Drag the edges of the viewport to adjust its size and to show what you want to see of the model.
  6. Now add the dimensions as needed making sure you are anchoring both ends to points or edges in the model.

Re: Modified scenes in LO. If you open a viewport in LO (commonly done by double clicking on it) to change the camera with Zoom, Orbit, or Pan, the scene will be shown as modified. Even if you inadvertently open the viewport but don’t actually make any camera changes, ‘modified’ will be displayed. This disconnects the viewport from the scene in SketchUp. That means any scene-specific changes you make in SU will not transfer to the viewport in LayOut. This creates all sorts of problems. For example none of the changes I suggested for your SU model would show in the viewport when the reference gets updated.

Really there’s no reason you should ever need to modify the SketchUp camera position in LayOut. You can change the size of the viewport and the size the model appears in the viewport by dragging the edges and corners of the viewport. Use Preserve Scale on Resize as needed. Tick the box to prevent the model size changing as you resize the viewport. Unstick it if you want to make the model appear larger or smaller on the page.

So with the proper set up, dimensions work as you would expect.


#36

Actual problem isn’t in viewport of skp in LO. The problem starts when You set dimension line to drawn objects in LO with scale you need (for this purpose You of course disable “Auto Scale” button). For examle, You draw (with tool “Lines”) in LO 2016 the wall with 3,5 mm of thikness (real 3,5 mm on A4 page), then You manually set dimension line for this wall with scale 1:100, but LO 2016 shows You incorrect value of this scale (anything but not 350 mm). Why is it difficult to fix this bug for long time I don’t know, but LO 2017 hasn’t this problem…

Roman


#37

Hey Dave, thanks for your extensive explanation. However most things aren’t the case. The camera is set to parallel, and the view alligned.
Back in LO, the scene turns álways Modified when I select a scale. Obviously I have to select a scale since the original scene (in SU) doesn’t have a scale at all.

Sometimes Layout/Sketchup has difficulties finding the end of a projection (especially with rounded edges in the axis you are looking). But since the fact that my Sketchup model was a simple 2d drawing, that could not have been the case.

Fact remains something is wrong with dimensions in Layout I’m afraid when using the Metric system… (for a very long time)


#38

Bjorn, in the file you sent to me, the scene was NOT set to Parallel Projection and the view was NOT aligned. Maybe you sent me a different file than the one you were working with? In any case, I wouldn’t have taken the time to write what I did in my previous post if the scene had been set to Parallel Projection when I opened the SKP file. There was also no option to select a scale for that viewport in the LO file you sent.

The scene will not convert to modified when you select a scale IF the scene was set to Parallel Projection in the first place. If you choose an ortho view from the drop down menu that will convert the scene to modified.


#39

Hm. I sure believe you if that’s what you say. Though in my version of Sketchup / Layout it’s set to parallel, 100% sure. Something mysterious is going on :). I’ll try making a fresh new file to see where that brings me