Did you know that SketchUp relies heavily on a good video graphics card?


#1

It’s true! Most processes in SketchUp use the graphics card for processing at some point. Whether it’s drawing a 3D face, rendering a texture on a model, or exporting a video animation - these operations (and many more) rely on the graphics card.

What does that mean for you? It means that your computer needs to have a 3D capable graphics card (eg. a card that boasts that it’s great for 3D graphics processing), a fast processor and a reasonable amount of RAM. The last two are a bit subjective, but if the graphics card that you’re looking at features those capabilities, it will probably be a good fit for SketchUp. Lastly, you’ll want a card from a manufacturer who provides consistent and regular drivers for the card. Drivers are the set of instructions that the Operating System uses to talk to the graphics card. If those instructions don’t make sense because of bad drivers, you’ll probably see issues in SketchUp. Updating your drivers frequently is something that we recommend:

Update drivers - http://help.sketchup.com/article/36254

What about makes and models for graphics cards, you might ask. Unfortunately, the variety is so large that we could hardly provide a definitive list. However, the common brands to look for are NVIDIA and AMD. These companies produce cards that are optimized for 2D graphics (i.e. for Photoshop) and for 3D graphics (i.e. for SketchUp :smile:). You want the 3D version.

Even with a great card and a great computer, there are some things that you can do in SketchUp that can bring performance to a screetching hault. To help prevent those kinds of issues, check out these Knowledge Center articles which give tips on settings and modeling techniques to help keep SketchUp humming along:

Making SketchUp run faster - http://help.sketchup.com/en/article/36235
Making SketchUp render faster - http://help.sketchup.com/en/article/161352


New to sketchup and unable to get continuous outline. laptop has intel hd graphics. is this good enough?
New Install BugSplat
The SketchUp working area appears pixelated
When I export to jpeg, the object seems as lines
Selection box does not display when dragging the mouse
Geometry outlines appearing all over the place
Graphic card recommendation
[Graphics] Random background linesss
DWG Export Issue
Push/Pull problems
Hardware Purchasing Advice For SketchUp & LayOut [wiki]
[Graphics] AMD/ATI Radeon - Dotted grid on startup
Dimensions not showing correctly (garbage in text box)
Glitchy image when exporting 2D Image
Sketchup not updating changes
#2

#3

Even with an updated driver and sketchup 2014, I keep getting this error message:
The NVIDIA OpenGL driver lost connection with the display driver due to exceeding the Windows Time-Out limit and is unable to continue.
The application must close.

Error code 7
Would you like to visit
http://nvidia.custhelp.com/cgi-bin/nvidia.cfg/php/enduser/std_adp.php?p_faqid=3007 for help?

Sketchup support is entirely unhelpful.
Any help would be greatly appreciated!


#4

Does the error go away when you apply the settings suggested in this Knowledge Center article?:

http://help.sketchup.com/en/article/3000055

The error codes aren’t exactly the same (6 vs. 7), but it’s worth a shot.


#5

Even though I didn’t “unpin” this thread it doesn’t stay on top as should. What went wrong?


#6

I’m posted to maybe help some other users out there:
Sketchup 2014
Dell Precision M90 Laptop with Windows 7, video card unknown.
Previous 2013 ran fine for client meetings.
2014 resulted in memory parity errors and a blue screen, even with the simple twist of the model.
I shut off hardware acceleration and now back up and running, which if fine for what I’m trying to accomplish.


#7

Here’s a handy utility that’ll tell you what’s under the hood.
Speccy by Piriform is an advanced System Information tool for your PC.


#8

video card unknown.

You may actually be able to use a command that is built in to Windows to see what kind of video card you are using. Try hitting your Start button and typing “dxdiag” (minus quotations) into the search bar. It should bring up the Direct X Diagnostic Tool, which first asks if you wish to check for signatures on your drivers. After saying ‘yes’, your first tab will be your system information. Click on one of the ‘Display’ tabs and the name of the device is generally the video card you have installed. Hope this helps…

~Drew


#9

If the old Dell brochure found googling is right, the video card ought to be one of three Nvidia Quadro FX mobile card options. You could go to the Nvidia website for a more up to date driver. The cards do not have the amount of video memory recommended in the current specs, but I have used SketchUp with much less than they have, with no problems.

Anssi


#10

I have a Surface Pro3… nothing in Device manager refers to a graphics card. Sketchup won’t work on a Surface Pro3?


#11

In your device manager, look under the “display adapters” item. But the Surface Pro have been running SU, search this forum.


#12

the MS Surface Pro does have an integrated Graphics Processing Unit (GPU) built in the Central Processing Unit (CPU), not ideal for using with a 3D modeler (slow, OpenGL support of driver) but should work for low-poly-count models.

check what’s built in by searching and running “dxdiag” (see tab “Display”).


#13

Thanks you for your knowledgeable reply! I discovered the issue of the rectangle disappearing after entering deminsions: The 2"x4" rectangle was so small for the scale on the screen it just disappeared! I’m trying to figure out how to change the scale. Currently using the zoom wheel on the mouse… but that’s a pain.
Thanks again. Tom Harmer206-228-8662


#14

Thanks you for your knowledgeable reply! I discovered the issue of the rectangle disappearing after entering deminsions: The 2"x4" rectangle was so small for the scale on the screen it just disappeared! I’m trying to figure out how to change the scale. Currently using the zoom wheel on the mouse… but that’s a pain.

Thanks again.


#15

After creating the rectangle do zoom-extents


#16

It isn’t a scale issue. You’re trying to look at the 2x4 rectangle from down the block. Move the camera closer to see it. Zooming is one way or as Steve suggests, use Zoom Extents to quickly zoom in on it. If your use for SketchUp is modeling objects around that size, it makes sense to create a template with the camera already zoomed in. Open a new file, draw a small rectangle and zoom in on it. Delete the rectangle and then use File>Save as template to create a new default template.