Did I muck up my settings?

First, I’m using a very old computer keyboard right now and have not tried this at my work computer.

You guys aren’t going to believe this. I can’t seem to change the number of segments in a circle in Sketchup 2015 Pro anymore. I don’t think I forgot how to use it but I’ve been known to have forgotten bigger things.

I’ve tried directly typing the number after just picking the circle tool. If I remember correctly, you pick the circle tool, then type the number of sides followed by an “S” and then hit enter? I’ve also tried hitting “S” first, then 100.

If that’s right, then I guess my old keyboard is fubbered or I have accidentally changed a preference?

I’m embarrassed but curious to know.


sorry remove…

Why remove, did you have some good advice for me?

I’ll try my other keyboard at work tomorrow. I’m hoping it’s just my home keyboard or something simple like that.

This doesn’t seem like something your keyboard would do without the problem being noticed in other apps as well. Also, its certainly not a SketchUp preference, though I suppose a system setting could affect keyboard input.

I assume that after selecting the circle tool you just type the number+s, such as “32s”, followed by return/enter? That is, do not click in the measurements box! You should also be able to change the number of segments by drawing a circle and then immediately typing the revised number of sides, and again you should see the value echoed in the measurements box.

If that’s what you are doing, your memory is not at fault!

OK, Gents

When I got to work today, on my other computer it works fine.

I simply the number of segments I want immediately after picking the circle tool.

So I think there is something wrong with my numbers keypad on my home computer.

And sorry about the slang. I have a bad habit of surfer talk from here in Cocoa Beach. We tend to make up our own words.

I’ll try to refrain.

You didn’t mention you were using the number pad, did you check that the number lock was toggled the right way?

Hello, Box.

I was using the numbers at the top and I did check for numbers lock.

Either, I was not supposed to try hitting enter first or S,
Or that keyboard is broken.

Today, I was able to change number of segments immediately on my other computer buy just typing numbers right after picking the circle tool.

Thank you.

I’m not sure about the S… when i want to change the number of sides of a circle, I click the circle tool, type the number of sides I want, then hit Enter, then draw…

1 Like

There are several ways.

a. Activate the Circle tool and type in a Number + ‘enter’ [just N - no ‘s’] - before placing the circle and then setting its Radius - this Number sets the segments to be N - after entering the circles values you can keep changing the Radius + enter until another tool is activated, which will freeze the values.

b. Activate the Circle and place the circle, by picking or typing the Radius required + enter, when it is as you want, then you can type Ns + ‘enter’ [i.e. a Number immediately followed by an ‘s’] to change that circle’s segmentation - you can continue to type in new Ns values until you activate another tool, which will freeze the values

c. After the circle is made, but before it is incorporated into any 3d-geometry which will have locked its values of radius and segment-count, or split it into arcs, exploded it, etc - you can select a circle and use Entity Info to change either of those radius/segment values as desired…

1 Like

Thank you.

Well Gents, even with a different keyboard…(needed a new one anyways) and I still can’t type numbers into the information box after just picking the circle tool. Nothing changes at all so I cannot change the number of segments in the bottom right hand (measurement box).

Luckily, I can create any circle and just change the number of segment after the fact in the entity box. But still strange because Sketchup Pro on my laptop lets me just type right away, the number of segments.

open ‘Ruby Console’ and type in 0 to 9 on both the keyboard and the number pad…

do they both work there?


Are you clicking on the Measurement box with you mouse ?
When the tool is active you just type what you want and the values should appear in the Measurement box, clicking onto it breaks the flow of the input…
Note that this applies to a circle’s radius OR segment-count - and also to all other numerical input used by many tools, e.g. if you want to draw a line an exact length.


No, i don’t click on the measurement box. I can perfectly perform changing number of segments on my laptop running Sketchup Pro 2015 but on my Desktop it’s not working.

I am aware of how to simply click on the circle tool on the left side of screen from the tool choices, and I am to immediately type a number which would change the number of segments.

It’s very strange. The only thing I can think of is perhaps a Windows 10 glitch? (my Laptop is Windows 8.1 which is where it works fine, but the problem I have is running on Windows 10)

I can live with it. I’m just perplexed as to what is causing it.

Some time ago I asked whether other apps on that computer are also affected or is it just SketchUp. You didn’t answer. If you can’t get those number keys to work in any app, it is definitely some combination of your keyboard, computer, and OS. If it is SketchUp only, it remains truly a mystery!

Any chance NumLock is off?


I have Win 10 and do not see this issue.
However, as has been suggested, sometimes after a restart NumberLock is set OFF and the number-pad input fails - this seems random,
Have you double-checked that ?

Thank you for the ideas. I will check that when I get home. I have restarted the computer by now few times and still had the error, but I don’t think I investigated the num-lock enough. But I did noticed that the light was not on for number lock. But maybe it’s still registering as on.

The one thing I need to check is if the number keys don’t work on other apps. that’s a good idea that I don’t know if I checked.

But I used the onscreen calculator yesterday for some reason, and didn’t have any problems. And I never use the keypad numbers on the right of keyboard. I always just use the numbers above the letter keys. So I think the numbers do work correctly on other applications.

Thanks for all the suggestions. I’ll work on this later tonight. For now the mystery continues.

I think I should check preferences within Sketchup (assuming you can make your own “hotkeys”)

Sorry I didn’t answer you on that. Great point. I used the onscreen calculator yesterday and didn’t have any issues with using numbers above my letter keys.

I will see if the problem reproduces today.

I think Windows 10 update is finicky so I’m thinking it might have to do with that. There are tons of updates, almost 2 times a week, and my PC often says failed to load Windows 10 start-up.

I’m thinking I might want to do a fresh install for Windows as I’m starting to believe it has something to do with the Windows 10 update on my PC.

I have a very powerful gaming rig, so my hardware is probably fine.

Major update.

So I discovered this amazing evidence.

If I pick the circle tool from the “Large Tool Box” window… this is when changing the number of segments don’t work.

But… If I pick the circle tool from the main upper list, it properly lets me type the number of segments.

So it’s only the “Large Toolbox” on my desktop that is not working.

Guess I could close or turn off the Large Toolbox and then reopening it may fix the glitch.

But no one else has seen this glitch before?

does it work from the Shortcut key?