Deleting Material List from SketchUp

Hi There,

I was having a lot of issues with my Sketch Up today. It kept stalling with the spinning beachball and asking me to upload the latest version of Sketch-Up 2021. So I felt forced to update. There were no other options. But I lost all my custom materials again. In the past, I would delete the basic materials that come with teh package.

I used this method… /Applications/SketchUp\ 2018/

then trashing the old materials.

I emptied the trash and restarted my computer several times but they keep reappearing and now they are scrambled with all my custom materials so it makes it difficult to navigate. Is there a new way to permanently delete the old material files?

How do I get rid of them? They are so ugly!

There’s no reason to delete the materials in the first place. It’s easy enough to simply ignore them considering they aren’t even loaded into your model and there’s no reason you should have to see them in the first place.

Oh. I definitely need to delete them.

The picture above is what I see when I open my materials. It’s just too many headings and it messes up my work flow. I only want to see the materials I specifically chose to be there. Creatively - just seeing these ugly materials from SketchUp make me want to quit Sketch Up.

I’ve been able to delete the basic materials for the past 4 years. I don’t understand why it won’t let me now.

I’ve mentioned one of the ways above in my original question that was given to me in the past. It used to work.

“/Applications/SketchUp\ 2018/”

Another user gave me this advice below once before. And it almost worked but then the old materials reemerged.

“What I did was to use from Finder: Go Menu → Library → Application Support → SketchUp 2020 → SketchUp → Material and then copy the content of the Material directory. Then navigate using the same procedure but this time use SketchUp 2021 and then paste in the Materials directory.”

I was also using this method before but I can’t seem to find the Ruby Console anymore.

from Make ‘Ruby Console’…

v17_mats = Sketchup.find_support_file('Materials')
v19_mats = v17_mats.sub('17', '19')
`ditto "#{v17_mats}" "#{v19_mats}" `


This is all I want to see when I open my materials list.

Here I deleted each individual list from my sketch up material list but they will come back when I open a new file. It’s a big difference to having to work with the alternative where they all show up. You can see the difference below.

Be aware that each Finder action (eg. deleting or adding folders) only will show up in Sketchup when it is restarted!

Altering lists inside SketchUp will show up in that session, but you have to close SketchUp normally (eg. Not force quit or crash) to be permanent in the folder structure.

So, there are three locations where SketchUp is looking to load the lists upon startup:

The package contents
The user library
The path that is set in [menu] File > Preferences > Files

(The last two could be the same)

When installing a new version, it automatically uses the package content in the version of your region settings (language) and takes over the Preference path.

In your case (where you want to get rid of the ‘ugly’ files) you can set the Preferences to a folder that contains your beautiful lists, then close SketchUp and delete the package contents in the English contents and the language that is set in your system.(The package of SketchUp contains all available languages on Mac)

Close SketchUp again and do a restart to see what lists are loaded.

In general, it’s easier to have a folder on your system that contains your beautiful lists and in the Preferences have it set to that path. Each new install will look for that automatically.

Sidenote: The ugly materials that have been around for two decades have almost reached an iconic position in the (pre) design world; everybody recognizes SketchUp’s brick or cladding material.


Thank you, Mike,

I will give this a shot and report back to you. Funny what you said about the ugly materials reaching an iconic position. :slight_smile: Even so, there must be a large group of SketchUp users who wouldn’t miss them at all! :wink:

I looked in all these folders (the 2 last ones are the same)

For the 2 last folders the Material list is empty because I deleted it. The first 1 in Package Contents has my new list.

But the old list keeps reappearing. I don’t know where my computer is finding it.

I live in Canada. You lost me on how to set the region setting. How do I change the Preferences and set to the right path?

I can see it, too. It might have changed…

1 Like

Okay. Hopefully, there is a way. It’s so confusing to have both lists (mine and SkUp’s all mixed up). Let me know if you figure it out. It used to be easy to do but something has changed.

Is this an OS thing? On my PC, I renamed the Materials folder in ProgramData and now it doesn’t load when SketchUp starts. Only my custom materials collections show in the drop down list. That said, even when the OEM Materials are allowed to load, my custom materials are shown below a divider in the drop down so they are easy enough to find.
Screenshot - 7_28_2021 , 8_17_18 AM

1 Like

Yes, an OS-thing. While trying to be more consistent in how SketchUp looks by disabling things in the Entity panel, they forgot the material panel :smiley:
It seems that SketchUp is trying to create a folder in the user library (‘Shipped Materials’) and then downloads(?) the folders…

I’m not sure if this is just an OS issue. But it would be nice if Sketch Up gave us some flexibility with the materials so they can easily be customized.

I will try your suggestion of renaming the materials list. But the problem now is that I deleted the SkUp Material List and I can’t even find it to rename it.

Check this: (7,9 MB)

Okay. I looked at the Shipped materials you sent. They are the original SkUp Materials List. For whatever reason my SkUp is finding these even though I deleted them and emptied the trash and restatred my computer. Now I have these new Shipped Materials you sent me. What should I do with them?

It is an OS thing, Mac users don’t get the dividing line, custom material folders are jumbled in alphabetically with the stock ones.

I start all my custom folders with “zz” to keep them grouped at the bottom. Kludgy, but it serves the purpose.

1 Like

oh srry, I thought you had lost it!
I removed the Materials from the contentpackage, and deleted the “ShippedMaterials” in the user library:

1 Like

One more reason I’m happy to be using SketchUp on Windows I guess.