How to recover a material list?

Hi, I was going to delete one material, but accidentialy deleted the whole list.
Is there any way to recover this list. Or is there a Sketchup Page where I can download it again?
I tried to reinstall it, but this did not solve the problem.

Thanks,
Inga

1 Like

the only way to delete a List is if it’s in the model…

if saved into your User Library, it will still be in the drop down menu…

if the files still open, you can try ⌘Z after clicking in the Color Panel

or File >> Revert from the menu…

do you have an earlier version of the model?

john

How did you “delete” it? Were you deleting files? Did you right click and “Remove” them from the In Model list?

The list is not in the drop down menu anymore. I was not able to just click back.
I have the old version from the back up file. But even when I open that the whole list is gone.

When I open a new file, the list is gone.

I was not deleting files. I added one single material to the list “concrete”. I found out that I won’t be able to use this material, and wanted to delete it.

This is how I removed it:

:

I should have pushed the Color button but I didn’t…

did you not get this dialog…


john

Yes, I got this, but since I was sure I only remove the material I clicked remove.

it’s still in SU, I’ll dig up some code to reinstate it…

john

1 Like

Do you indeed have the option set to create a back up? Even if you do, that is the backup of the last saved file so if you wake error and then save the back up does what it is designed to do.
Do you also have the option set to periodically save files. If so you may have one version saved before the issue happened so check if that maybe the case.
Sorry John missed your post:grimacing:

I opened the backup and the list is gone. It seems to be completely gone. Even if I open a new file, or open one of my old files. It is not there anymore.

I just installed the 2016 yesterday, and even there the list is gone. I am confused, but I am sure there was a “concrete list”

open ‘Window’ >> ‘Ruby Console’ from the SU menu and paste this in the bottom input feild and hit return…

 brick = Sketchup.find_support_files("", 'Materials').grep(/Brick/)

that will confirm it’s still there…

I’ll see I can find where they turn it off, as this is a new thing to me…

john

Looks like it is gone:

remove the lowercase c from the grep…

I just ‘Removed’ the collection from my SU, so I can now look for a key…

@TheOnlyAaron when was this introduced, I don’t recall being able to remove them on a mac before…

john

Did you mean like this?

you had an > that shouldn’t be there, but while you digging your, you can see the folder in Finder by using

brick = Sketchup.find_support_files("", 'Materials').grep(/Brick/)
`open -R #{brick[0].inspect}`

they haven’t turned it off where I would expect, which makes it hard to turn back on…

@Barry or @bugra, where’s the plist for these?

john

that is helpful thanks, but even in the Finder the folder concrete ist gone…

They’re not in defaults on Mac. They are in the the app wrapper, so I fail to see how a re-install wouldn’t work. The skm files are stored at /Applications/SketchUp 2016/SketchUp.app/Contents/Resources/Content/Materials/Brick, Cladding and Siding/

cheers at @Barry, why can you turn them off but not back on?

the missing folder of @inga is ‘Asphalt and Concrete’…

I removed the other from my ‘List’ thinking it would be noted in a ,plist…

but as you say mine is still in App contents…

john

Mystery solved!!! Thak you for all your help. @john_drivenupthewall, thanks for just saying my missing folder is ‘asphalt and concrete’. I forgot about thr 'asphalt" and only kept looking under c.

I think the reinstallation worked after all.

I tried deleting “Metal”. As soon as I quit and restarted SketchUp, it came back. Sounds like a bug - we should disable the Delete if you truly can’t delete.