Can't delete duplicated material

Hi there

1st post from a newbie in SU. So hope question wasn’t already asked but couldn’t find it there

I imported new material in SU but sure I did something wrong. I have now duplicated material (mainly wood) I can’t delete. I tried to do it from material window using Delete but material appears again when I restart SU :rage:

Seems that I can’t remove any material

FYI I’m using SU on iMac (Nobody’s perfect :grinning:)

Thanks in advance for your help


Does purge materials work?

Maybe you are deleting the original file instead of the duplicate? SketchUp might try to repair itself if you are deleting stuff from the shipped libraries.

Hi thanks for your fast replies


No. Purge option is not active


Even if I delete the 2 same materials I’ll have both displayed again after restarting SU

Looking at my HDD I discovered some SU 2916 folders. I deleted them but same issue :persevere:

Are you looking at the In Model materials or the collection of wooden materials? Perhaps you have accidentally duplicated the material file in the material folder, not the material entity in your currently opened model.

Hi again

I don’t think so as I open directly the material collection by clicking Texture Pallet icon (Red circle) and Wood/Bois collection (Bleu rectangle)

What ever the model I select starting SU I have same issue. Wood collection appears only once in list and material folder on my HDD is empty

As you are on mac, the default materials are not in the Application Support/SketchUp ####/Matierals folder. The default materials are packages with the app.

Thanks @TheOnlyAaron for this info. Is that the same for ‘added’ materials?

Just make a new test importing ok a new structure but no way to delete it :cry:

You can add your own materials by creating folders int he Materials folder and filling them with .SKM files.

Hi @TheOnlyAaron
I just did it as you wrote. I create a new list in Material Collection “Mes textures” and the corresponding folder appears in the the Material folder. I add a .skm file that appears in the list perfect :grinning:

But same issue as above, I can’t delete it from using “delete” option. I have to delete .skm file from Material folder to remove texture from Material collection :unamused:

Could it be a SU installation issue?

Not 100% sure, but that sounds like a rights issue. When you installed SketchUp, did you “Install as Administrator”?

Normally yes as I installed dmg file from Admin account. I have only one account on my iMac and it’s admin one

Will try to uninstall & re-install SU

to be continued… :upside_down_face:

installing with an account that has admin privileges and installing by clicking “Run as Admin” on the installer are not quite the same… Check this out for more info:

I’m using Mac so don’t think so I have “Run As Administrator” option as on Windows PC. I just need to be logged with an account that has admin privileges. I’m right?

Oops! Yep, that should work… You may want to check and make sure that there are not some odd rights set on the Materials folder, too…

Just re-install SU following procedure there

and same issue I can’t delete texture from Material collection. But no more duplicated textures :slight_smile:

Will see one day I’ll find the pb… :thinking:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.