Deleting Edges for good!


So I kept noticing that when trying to redraw my wall, the edges of the face were separate edges. I would delete the whole face and edges to create a fresh face to create a wall and for some reason, it’s as if SketchUp remembers the three separate lines no matter how many times I create a new face or (wall).

I was also surprised that my trick of revealing the edges tab, drawing a line, and then deleting that connected edge with the line would not form one edge. :confused: - This method ALWAYS works.

Check the video below to see what I mean.

Please drop down 1. why this is happening and 2. What do I need to do?

I’m teaching myself and would love to know why and how to overcome these snags in the future.

Kind regards


Try with viewing ‘Hidden Lines’ on to see if you really got rid of those endpoints that keep bothering you.

1 Like

Oh grand.

Thank you.


I can’t understand why I keep having multiple endpoints when drawing a single connected line.

In the screenshot below, I have my endpoints on and my hidden line on so I can see the necessary geometry to get rid of.

Unfortunately, I haven’t been able to create just one single line.

Any clues???

Without I seeing your model, one guessing is that you have a loose geometry associated to hidden Tag.


Not yet.
But if you share the file I may have. I guess there is still geometry that you can’t see now. Maybe because there are ltags turned off with geometry “on” those tags

Oops, and now @dezmo shows exactly the same thing just before I get there.


other possibilities include :

  • your work is based on a dwg/dxf, and it is a poorly drawn one (like cadastral ones in france, nothing is exactly straight or perpendicular)
  • when drawing, you retraced over an existing line several times.

But yeah, probably the tag thing Dezmo and Wo3Dan are talking about.

Several times but look closely at OP’s video (first post) starting from 1:23 / > end. The edge is drawn in empty space from left wall to right wall. So there must be invisible endpoints on its path.

1 Like

One of the most common reasons for this, aside from bad tagging, is hidden geometry created by using the Eraser tool with Shift.
Softened edges created with crtl and the eraser will generally be deleted when the face they are part of is deleted.
Hidden edges, on the other hand, will hang around floating in space waiting to mess up your work.
Shift with Eraser should only be used when you really understand what it is you want to do and why, remember hidden things are still there even if you can’t see them.

1 Like