Default Shortcut command gone missing - Edit/Item/Explode


#1

I recently had to reinstall SU 2016 Pro as suddnely failed to open any file on my server.

THe reinstall worked ok but I had to go thru and reinstall my shortcuts

I have them on a file so reloated that and yes most worked BUT

I have a very frequently used shortcut “X” to explode a group…

It is a shortcut of the standard command sequence EDIT/ITEM/EXPLODE

But when I typed X nothing exploded…

Checking the shortcuts dialogue box under preferences the shortcuts no longer lists EDIT/ITEM/EXPLODE as a command sequence I can shortcut …

To make sure I removed all plugins / extensions to have SU only show me the deafult shortcuts…

Restarted SU again and still no EDIT/ITEM/EXPLODE listed ?

Thinking I was going mad, I checked another SU 2016 machine ans sure enough it is there !

I am using the latest version 16.1.1449 64bit

The machine I checked that still has the EDIT/ITEM/EXPLODE is version 16.0.19912 64bit [hasent been udated]

So question is

1] Is my SU install corrupted ? or

2] Has Trimble removed that command sequence in the latest update ?

If they have I am annoyed !


#2

X is not and never has been a default shortcut for Explode. You must have set it to that yourself. X is normally used with Move/Copy and Rotate/Copy to make arrays.


#3

To be able to see that command, you must first select a Group to which it can apply. That’s why you can’t initially see it in the list of commands - it isn’t available unless there is a selected Group - which there won’t be in a new drawing.

As DaveR says, it isn’t always advisable to use X since that is used in Move/Copy and Rotate/Copy commands to indicate how many copies to make. But if you type nX (make ‘n’ copies) instead of Xn, you can avoid that conflict.

Why do you so frequently need to explode Groups? You don’t need to Explode a Group to edit it, for example.

Just curious, as I (a) hardly ever use Groups, preferring Components almost always as they are much more versatile, and (b) rarely need to Explode either Groups or Components.


#4

@DaveR: I don’t think the OP said that X was the default shortcut for Explode Group, just that there is a standard command sequence Edit/Item/Explode


#5

Thanks Dave

, but your misunderstanding the issue

I am not talking about “X” being the default - I am talking about EDIT/ITEM/EXPLODE being default and it is now missing from my SU install but still exists in an earlier SU install on another PC…

Tried to attach the screen capture above… showing the command seqence that has gone missing!


#6

@john_mcclenahan, from his title and description it appeared to me that he expected X to be the default shortcut, which of course it is not. A keyboard shortcut can be set for EDIT/ITEM/EXPLODE by selecting an entity which can be exploded and then filtering the command list.


#7

It does indeed still exist. Select something in the model that can be exploded and then filter for it.


#8

The key I assign to a command can be anything I want, the issue is the EDIT/ITEM/EXPLODE sequence has vanished from my install!


#9

Yes it can. Although be aware the operating system native shortcuts can override.

This is what made me think you expected X to be a default shortcut for Explode.

Except it has not vanished. Like any command that shows in the Context menu, it only shows in the list when there is a selection that would cause them to show in the Context menu.


#10

Have you missed selecting something to explode?
Note selected group under the dialog.


#11

Here is my screen capture - excuse the bad mouse writing –

I want to add a shortcut for explode - [Yes I have explode in the context menu when I right button] but I do NOT see it what I go into preferences / Shortcuts in the list of standard command sequences !


#12

As we have said, you must have something selected in the model that can be exploded to get it to show in the list.


#13

DaveR - I have been using X as a shortcut to explode groups for almost 10 years - now I cannot reassign it in the lastest install of SU 2016 - my simple question was - is my SU 2016 install corrupted or is it missing from the latests SU2106?


#14

And here, no selection, no menu item.


#15

We’ve been trying to help you.


#16

All three of the responses here have explained why you can’t see the command UNLESS YOU HAVE A GROUP OR COMPONENT SELECTED.

Your installation isn’t corrupt. And the command hasn’t ‘gone missing’.

Open an existing drawing with groups or components, select one, THEN assign the shortcut. The command won’t be visible in the list unless there’s a selection that CAN be exploded.


#17

OK Dave / Box

that worked - thanks

and my apologies if I sounded frustrated .

but I swear I have never had to have it selected before to get it to appear in the shortcuts menu…

and I cannot believe that is very intuitive way of establishing shortcuts

Thanks


#18

Maybe it should be added to the DUH-BOOK…


#19

I do have sympathy with your frustration, but slow down a bit and read the responses you got - the explanation was in my first response, and repeated twice more by DaveR and Box, until you ‘got it’.

And I’m still curious - why do you need this command so often in your workflow?


#20

Further comment on your feeling that you don’t remember previously having to have something selected when assigning the shortcut.

I just tried it again in SU 2014. No group or component selection, no Explode in the context menu - you don’t get it when you select raw geometry.

No selection, no Explode command in the Shortcuts lists.

It’s always been that way AFAIK. So probably your recollection is a false memory - we all get them at some time.