Default Line-Weight for Drawings in SU 2015


#1

I am a total beginner and I downloaded the trial version of SU 2015.
I am also following a tutorial from Infinite Skills - Learning SketchUp 2014.
What I noticed is the drawings of instructors are very clear and legible as the lines drawn on the screen are very thick.
However for me, the lines are very thin and its started to feel very distracting and needs me to focus more and be closer to the screen to get operations right.
I am using a Macbook Pro with Retina Display … not sure if thats why the lines are showing as super thin.
Reference images in the pdf attached below.
Lineweight.pdf (1.6 MB)
But how can I change the default line weight so it looks more like how the instructor has in his videos?

Please see screenshots for reference.

Thanks,
Dev.


#2

Hi,

SketchUp doesn’t really have a lot of adjustments you can make specifically for line weight settings (not incrementally the way you can in AutoCAD, or the way you might scale the size of a font). To change a line style around you really need to look into changing what Style you’re using within SketchUp.

See… >Windows >Styles, and click on some of the available options. They’re not all visible up front; you’ll want to navigate the pull down menu to access the majority of them.


There are some line weight adjustments, which are available within ‘Layout’. And you can also create your own Style by using a program called ‘Style Builder’. Both ‘Style Builder’, and ‘Layout’ are free companion programs that come bundled into the SketchUp Pro licensing option… and these programs are also something to think about concerning your evaluation of SketchUp. Take a good look at them in addition to the main SketchUp program…

Quick Summary:

‘Layout’ – specializes in document creation which includes arranging 3d SketchUp models onto a 2D Page format (printed, or digital). Layout isn’t limited to just large project construction documents, it works equally well with single page, or multi-page layouts. and has some nice features which make it easy to create tight continuity, and consistency between multi-page docs.

‘Style Builder’ – as already mentioned allows you to combine your own line work, so that you can create a ‘Style’ for use within SketchUp. Basically you print out a template, and draw in your own line work. Then you scan it back into the program where it in turn converts your line work into a usable SketchUp ‘Style’. (Line weights happen here, by drawing in thicker lines).


Having said all of that. I suspect that the major issue at play here, has to do mostly with your instructors screen capture program, whatever s/he’s using probably doesn’t handle line weights with much finesse, which is to say that it’s very common to see a fine line weight generated from any CAD program get enlarged or scaled to a heaver weight in another program. The same thing can happen in a PDF file depending upon how it’s generated. . . which, in this case, given the line weight settings found within SketchUp’s ‘Layout’ program – you do have some adjustment over this.

Also, screen resolution does affect things, but in addition to seeing line weights change some, you’ll also see the size of menu text, and tool icons get much smaller. Depends upon the settings used on your Macbook Pro. See… >Apple Icon (Top Left) >System Preferences >Displays. . . Resolution – Display (tab):

[] ‘Best for Display’ = resolution adjustments happen automatically.
[
] ‘Scaled = you can adjust slider to a couple of different options.

Hope that’s helpful,

Jim


#3

The problem is the Retina display.
Sketchup does work well with it.


#4

Ok … so the styles dont have anything to play with line weights.
I tried playing with the display resolution and lesser resolution does seem to “thicken” the lines but messes up other apps and overall experience.
So I am guessing I am stuck with super thin lines right now till Sketch up gives an option to play with line weights.
Just wondering if its so hard or never really being pointed out … or really is it just me? Does not seem to bother others :smile:

Thanks for your inputs


#5

Hi,

I’m guessing that you didn’t find a more suitable style to use – if you’re now waiting for the development team to introduce traditional line weight settings into SketchUp. You did have a few options however, and I’d encourage you to poke around a little more, or at least try the following.

Your current style can be adjusted by clicking on the ‘Mix’ (tab), of the Styles window.
Then choose another style and drag it on top the ‘Edge Settings’ category, and drop it there.
Try using one from the ’Straight Lines’ collection, which pretty much have progressively thicker lines which you can easily see in the preview icons. Even the options on the top row make a noticeable difference if placed ontop of one of the default engineering styles.


ALSO:
You may need to go into the Edit (tab),. . . Activate the Edge settings (by clicking on the Edge Icon), and then adjust the ‘Level of Detail’ slider some. Lines might not always extend to your models outside edges, or even show up at all (for narrow areas). Increasing the level of detail should fix these issues. And then while you’re there Playing around with the ‘extensions’, or ‘halo’ values can add some nice effects to your drawing. and so can the ‘Depth Cue’ for that matter.


I’m also running SKetchUp Pro exclusively from a Macbook Pro (retina).
But I like thin lines and don’t have a problem with them. However I have used plenty of styles which have a little thicker line weights.


#6

Accidental reply that I can’t delete - Best if Ignored (or then again it could be the best thing I’ve said so far in this thread).


#7

Jim D, I will choose latter (Best thing in the thread :smiley:) … I just turned on the Profiles in the existing style - Shaded with Textures and bingo - I got what I wanted. Also increasing the profile value thickens the lines.

Just wanted to update here so future users can find a quick setting. Will learn about Style Builder and Styles as I progress in the tutorial. So will update the thread if needed.

Thanks for your help again.


#8

My problem with a retina has been seeing highlighted elements. They turn blue but it’s rather muted and sometimes doesn’t show up without rotating the view. I’ve found that turning “profiles” off actually helps. It makes the line weight very thin (which is not really appreciated) but it does make the blue come across much better. I don’t seem to have this issue using Sketchup on other monitors. I’ve read mention on the interwebs that you can change the highlight color but I’m not sure exactly where this is adjusted.


#9